The Problem About Making LAMMPS.

Dear All,

I’m trying to build LAMMPS. The OS version is:

LSB Version: :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: Scientific
Description: Scientific Linux release 6.5 (Carbon)
Release: 6.5
Codename: Carbon

So,I modify the Makefile.g++3 according to Section 2.2.It works well for lammps-14Feb14,but an error appears for lammps-24Feb15.

[[email protected]…125… src]$ make g++3
make[1]: Entering directory /home2/cwang/LAMMPS_FAST_INSTALL-v5.0/lammps-24Feb15/src/Obj_g++3'* *../../lib/quip/Makefile.lammps:7: /build./Makefile.inc: No such file or directory* *egrep: /Makefiles/Makefile.: No such file or directory* *egrep: /Makefiles/Makefile.: No such file or directory* *egrep: /Makefiles/Makefile.: No such file or directory* _../../lib/quip/Makefile.lammps:17: *** fortran compiler >><< not recognised. Edit lib/quip/Makefile.lammps to specify the fortran library your linker should link to. Stop._ *make[1]: Leaving directory /home2/cwang/LAMMPS_FAST_INSTALL-v5.0/lammps-24Feb15/src/Obj_g++3’
make: *** [g++3] Error 2

In fact, I did​n’t attempt to add QUIP package.So the problem looks like strange.Can you give me some advice?

Best Wishes!

Sincerely yours,
Chen Wang

I suggest you do a make clean-all, and

insure there is no “quip” in Makefile.packages or

Makefile.packages.settings.

And type make package-status to insure

the USER-QUIP package is not installed.

Steve