The simulation crashes but I don't gey any error message

Dear LAMMPS users,

Please help me to figure out what’s going on:

LAMMPS starts running my simulation, but every time the simulation stops at the same timestep.

I mean, when I type “top” in a terminal window, LAMMPS is still running with the processors being used. However, the .log file don’t refresh anymore.

Below, I show the last three lines in the .log file. The last timestep printed was the 279000.


277000 -1399.7751 -1259.0915 292.79139 297.61658 298.25044
278000 -1201.9679 -1439.7572 282.26513 296.44168 298.64779
279000 -1040.0476 -1486.0827 297.81793 295.78242 296.87497


I tried running the same system with the same conditons several times and it always happens in the same timestep.

When I change some conditions (temperature, nve/sphere x npt/sphere fix, etc) the same thing happens. However the .log file stops refreshing in different timestep (for example, 462000) and always stops in this other one. Different conditions the simulation stops in different timesteps.

I also tried changing a compute cluster/atom command that I’m using. When I set the cutoff needed in this compute in 3A the simulation completes my one million timesteps (with the fix npt/sphere, but not with the fix nve/sphere). When I change to 4 angstrons happens what I described above (for both fixes).

Some more possible informations about my system:

atom_style hybrid molecular dipole sphere

pair_style lj/sf/dipole/sf 9.0
special_bonds lj 1.0e-50 1.0e-50 0.5 coul 1.0e-50 1.0e-50 0.8333
pair_modify mix arithmetic
bond_style harmonic
angle_style hybrid cosine/squared dipole harmonic
dihedral_style charmm

I REALLY don’t know what’s going on. Any help I would appreciate.

Thanks in advance.

Hi Rafael, is it possible that the compute cluster/atom instance you have defined is using too much memory? Is the machine that LAMMPS is running on responding after you see output stalling?