Too many sorting bins

Hi everyone,

I am calculating the thermal conductivity of a cross structure of which the two ends are fixed. But now I am facing two problems. The first one is that after balancing the temperature at 300 K with fix nvt, the temperature of the system is about 270 K rather than 300 K. I have already change the Tdamp parameter, but it doesn’t work.

The other is when the structure is heated by constant flux with fix heat command, the error “too many sorting bins” will come out to stop simulation. I tried to increase the parameter of bins (now I use 2.0 nsq), however, it cannot solve this problem. What’s more, I find that the cross part departs from its original position too much.

Could anyone please give me some suggestions?

Thanks,
Yang

Hi everyone,

I am calculating the thermal conductivity of a cross structure of which
the two ends are fixed. But now I am facing two problems. The first one is
that after balancing the temperature at 300 K with fix nvt, the temperature
of the system is about 270 K rather than 300 K. I have already change the
Tdamp parameter, but it doesn’t work.

​the default temperature in thermo output will compute the temperature for
the entire system. if you immobilize some atoms​, then the total system
temperature will be lowered, since some atoms will be at 0K while others
are at 300K (in your case). you have to look at the temperature
specifically for the mobile system.
please read the documentation for fix nvt very carefully, it has
information about how you can access the temperature compute that is used
by the integrator, which should reflect the target temperature. Tdamp has
nothing to do with this. ...and if Tdamp *would* have an impact (once your
system is in equilibrium, that is), then this would be an indication of
some other problem, e.g. too large a time step or overlapping thermostat
groups or similar.

The other is when the structure is heated by constant flux with fix heat
command, the error “too many sorting bins” will come out to stop
simulation. I tried to increase the parameter of bins (now I use 2.0 nsq),
however, it cannot solve this problem. What’s more, I find that the cross
part departs from its original position too much.

Could anyone please give me some suggestions?

you can explicitly set the size of bins for sorting or disable sorting with
the atom_modify command. for all but very tiny systems, you should not use
"nsq" neighbor lists, as it will significantly slow down your calculation
(through slowing down the neighborlist builds). with recent LAMMPS
versions, the currently active binning parameters will be output to the
screen and log and you can adjust them accordingly, if you see anything
unusual.

axel.