Unable to use USER-INTEL package

Hi!

When I try to run a script with `-sf intel`, I get the message:

    ERROR: Using suffix intel without USER-INTEL package installed (src/
lammps.cpp:770)

During compilation, I did use the flags:

    -DPKG_USER-INTEL=yes
    -DINTEL_ARCH=cpu

along with the flags for USER-OMP (which is usable). So when I look at the out
put of `lmp -h`, I see this:

    Installed packages:
    KIM USER-INTEL USER-OMP

But none of the pair styles or the fix styles listed have any 'intel' styles.
The do have the 'omp' styles.

Another (possibly related) issue I noticed is that in-spite of specifying the
relevant cmake flags, I also had to provide:

    -DCMAKE_CXX_FLAGS=-O2 -fp-model fast=2 -no-prec-div -qoverride-limits -
qopt-zmm-usage=high -qno-offload -fno-alias -ansi-alias

for otherwise, it was using some gcc-like options (for eg. -march=x86_64).
All the "COMPILER_SUPPORTS" tests of those (intel-like) options are shown to
have 'Failed'. But If I do specify the CMAKE_CXX_FLAGS, they show 'Success'.

So it seems like that isn't working very well, or I'm doing something wrong
during compilation.

LAMMPS version: 29Mar2019
Intel compiler version: 19.0.0.20190117 (OpenMP 5.0)
CPU: Intel Core i7-6700K

Can someone help me figure this out?

Thanks
Vishnu

there are quite a few issues with USER-INTEL support when using CMake to build LAMMPS.
i have tried to address them with a pull request, that i just submitted to github: https://github.com/lammps/lammps/pull/1398
this still needs testing, documenting before it can be included.

for the time being, i suggest you use the conventional build process or don’t include USER-INTEL.

axel.

Okay, thanks for letting me know. I should also have also looked through the
Pull Requests and not just the Issues before asking.

Thanks for getting on top of it so quickly!

Vishnu