Unsatisfied external latte.

I’ve been working to build Lammps 23Oct17 (development version) and believe I have LATTE compiler correctly in lib/latte/LATTE-master using Intel/17.0.1.132 and impi/2017.1.132. I believe links are set up to the correct directories to find liblatte.a etc. with –llatte in LINKFLAGS and CFLAGS along with the appropriate –L and –I arguments.

The final 'make results in …

     I've been working to build Lammps 23Oct17 (development version) and
believe I have LATTE compiler correctly in lib/latte/LATTE-master using
Intel/17.0.1.132 and impi/2017.1.132. I believe links are set up to the
correct directories to find liblatte.a etc. with –llatte in LINKFLAGS and
CFLAGS along with the appropriate –L and –I arguments.

     The final 'make results in ...

--------

/tmp/aai/brown/lammps/23Oct17_intel-17.0.1.132_impi-
017.1.132/src/Obj_mpi/../fix_latte.cpp:289: undefined reference to `latte'

--------

which is not an external found in liblatte.a (nor is latte_ which I looked
for upon finding an f90 subroutine named LATTE). I'm assuming there's a
cockpit error somewhere but wonder if fix_latte.cpp might be at fault.

​latte is included in the wrapper object: LATTE-master/src/latte_c_bind.o​
​which should be pointed to by a symbolic link filelink.o in lib/latte

axel.

Thanks for the prompt response. I’d overlooked setting up filelink and/or filelink.o (depends on where you read) so I set 'em both and am past the problem now. Sorry to bother.

Happy New Year,

Phil

P. A. Cheeseman
aai@…132…
765.496.8224