using output array of compute msd/chunk

Dear Developers,

The global array found by compute msd/chunk doesn’t seem to print correctly with thermo output or work with the variable functions, e.g. ave() in version 11 Sep 2015. I think this is because the number of rows in the output array is not set. Adding this line to ComputeMSDChunk::compute_array() seems to resolve it: size_array_rows = nchunk

Before/after example is below…

Thanks,

Tim

units lj
atom_style bond
special_bonds lj/coul 0 1.0 1.0
region box block -10 10 -10 10 -10 10
create_box 2 box

mass 1 1.0
mass 2 1.0

pair_style lj/cut 1.12
pair_coeff * * 1.0 1.0 1.12

create_atoms 1 single 0 0 -0.4
create_atoms 2 single 0 0 0.4

fix 1 all nve

compute cc1 all chunk/atom type
compute msdChunk all msd/chunk cc1

variable chunkave equal ave(c_msdChunk[4])

thermo 1
thermo_style custom step c_msdChunk[1][4] c_msdChunk[2][4] v_chunkave

run 10

LAMMPS (11 Sep 2015)
Created orthogonal box = (-10 -10 -10) to (10 10 10)
1 by 1 by 1 MPI processor grid
Created 1 atoms
Created 1 atoms
Neighbor list info …
1 neighbor list requests
update every 1 steps, delay 10 steps, check yes
max neighbors/atom: 2000, page size: 100000
master list distance cutoff = 1.42
ghost atom cutoff = 1.42
binsize = 0.71, bins = 29 29 29
Setting up Verlet run …
Unit style : lj
Current step: 0
Time step : 0.005
Memory usage per processor = 2.75844 Mbytes
Step msdChunk msdChunk chunkave
0 0 0 nan
1 0 0 nan
2 0 0 nan
3 0 0 nan
4 0 0 nan
5 0 0 nan
6 0 0 nan
7 0 0 nan
8 0 0 nan
9 0 0 nan
10 0 0 nan
Loop time of 8.60691e-05 on 1 procs for 10 steps with 2 atoms

Performance: 50192225.152 tau/day, 116185.706 timesteps/s
0.0% CPU use with 1 MPI tasks x no OpenMP threads

MPI task timing breakdown:
Section | min time | avg time | max time |%varavg| %total

yes, that’s the added line that’s needed. Will be in today’s

patch - thanks Tim

Steve