When special_bonds is 0 the neighbor_list will automatically exclude the pair neighbor?

Dear all,

When I request this kind of neighbor list, the neighbor_list for the nearest neighbor are excluded even with exclude none (without ewald solver). But when I set special_bonds to some value these neighbors can be given. Is there some way that I can get all the neighbor list with special_bonds = 0 0 0?

Dear all,

When I request this kind of neighbor list, the neighbor_list for the nearest
neighbor are excluded even with exclude none (without ewald solver). But
when I set special_bonds to some value these neighbors can be given. Is
there some way that I can get all the neighbor list with special_bonds = 0 0
0?

this has been discussed in the past several times. since the test for
exclusion from the neighbor list is against exactly 0.0, you simply
need to set it to a very small number that is different from zero by
so small it makes no difference, say 1e-10.

axel.

If you are just writing a compute that is a diagnostic,
you can also use it with the rerun command with
different settings for the special_bonds. See the
doc page for compute coord/atom for details.

Steve