Wrong primitive cell

The primitive cell for both mvc-14047 and mvc-11238 looks wrong.

I cannot reproduce the primitive unit cell neither using SpacegroupAnalyzer.find_primitive() nor using structure.get_primitive_structure() from the conventional standard provided.

The Computed structure looks alright, but that is different from the primitive one shown for the materials.

Can someone please explain to me what is going on here?

Hey Protik, thanks for the feedback, this looks like a bug. We’ll look into it and follow up when we understand what’s going wrong.

1 Like

Hi @Protik_Das,

Thanks for reporting this! @Joseph_Montoya and I have had a look into it this and the good news is that it looks like this bug has already been fixed at our end, and this should be updated on the website soon (sometime in the next few weeks).

The primitive structures shown on the website are cached, and are generated when the material is inserted, so there was probably an older bug in get_primitive_structure() (or possibly in our CIF writer code) that was later fixed. We will have to investigate further to confirm the exact cause.



1 Like

I’ve gone ahead and regenerated primitive cell CIFs for our structures using our current code. Let me know if this helps. Thanks.

1 Like

Thanks a lot!

Have you fixed it for all materials or only the materials I selected?

I fixed it for all materials for which pymatgen.analysis.structure_matcher.StructureMatcher.fit returned False given the online primitive cell structure and that returned by get_primitive_structure on the online computed structure. There weren’t many, but there were more than just the two you mentioned. Thanks for pointing out the inconsistency!

1 Like