A bug found in cif files maybe

Hello everyone!
I have found a bug(maybe it’s not, i’m not sure) in MP cif files when I download one and then open it with VESTA. The space group is always shown P1 no matter which kind of structure I’ve downloaded. Did anyone meet this problem or has already solved it yet? I wish you can give me some advices. Thanks!

Wuliji Hexige

Hello Wuliji,

This is expected (but also confused me in the past). For many types of ab-initio calculations, you typically don’t explicitly specify the spacegroup but rather just specify the cell parameters and atomic positions (e.g. in VASP). DFT relaxation may lead to very small deviations from the perfect symmetry-equivalent positions and when you determine the spacegroup of such a structure you typically take into account a certain tolerance. So, while no symmetry information is explicitly stored in the cif (P1), if you run the structure through software to determine the spacegroup (e.g. spglib which is used in pymatgen) the spacegroup is the one stated on the MP website.
If for some reason you still need the cif derived from the spacegroup, you can click on the cifs button (below the unit cell display of any material) and click on “symmetrized” to get a cif file that creates equivalent atomic positions based on spacegroup symmetry operations.

Hope this answers your question!


1 Like

Thanks for answering! The problem is solved and I know how to use the data now. Thank you very much!


1 Like