Airebo and kc

I am trying to run my old inputs with a newer lammps (stable 2019), and fail on these two lines:

pair_style  hybrid/overlay  rebo  kolmogorov/crespi/full 16.0 1
pair_coeff  * * rebo               ../CH.airebo-m      C C  # chemical
pair_coeff  1 2 kolmogorov/crespi/full   ../CC.KC-full   C    C  # long range

in multiple ways:

  1. Clearly the second rebo now needs to be airebo, since the format has changed, but that fails with the pair style command which doesn’t take airebo as an argument…
  2. Changing everything to CH.rebo fails on the “1 2” in the KC full line
  3. Changing this to kolomogorov/crespi/z works with rebo (of course not with airebo).

I am confused. The documentation is probably incomplete; I probably have some errors and misunderstandings in what I am and was doing. Any help appreciated!

Please note that a LAMMPS version from 2019 is still very old.

  1. It makes no sense to use an .airebo-m parameter file with the rebo pair style there is no rebo/morse since the REBO model does not contain the LJ or Morse component of the two AIREBO variants. If you do use the .airebo-m file you also must use pair style airebo/morse
  2. The KC-full line must fail, since that potential requires to use pair_coeff * *. It may not have checked for that before but it should have. So your old input was incorrect.
  3. kolmogorov/crespi/z does support the per type pair_coeff format.

You need to carefully study the documentation for each of the involved pair styles. The two interlayer potentials differ in how they tell the layers apart, IIRC, so you cannot simply swap them around.