Amset wave error

I’m getting the below error message when trying to generate the wave function coefficients (amset wave). I’m able to successfully run “amset wave” on other systems using the same version of vasp and INCAR file. I have tried adding “-v std” but I get the same error.

Thanks for any help.

******* Getting wavefunction coefficients *******

  - Spin-up bands 148—165
  - Spin-down bands 150—165

Traceback (most recent call last):
  File "/projects/anaconda3/bin/amset", line 33, in <module>
    sys.exit(load_entry_point('amset==0.4.15', 'console_scripts', 'amset')())
  File "/projects/anaconda3/lib/python3.8/site-packages/click/", line 1128, in __call__
    return self.main(*args, **kwargs)
  File "/projects/anaconda3/lib/python3.8/site-packages/click/", line 1053, in main
    rv = self.invoke(ctx)
  File "/projects/anaconda3/lib/python3.8/site-packages/click/", line 1659, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/projects/anaconda3/lib/python3.8/site-packages/click/", line 1395, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/projects/anaconda3/lib/python3.8/site-packages/click/", line 754, in invoke
    return __callback(*args, **kwargs)
  File "/projects/anaconda3/lib/python3.8/site-packages/amset-0.4.15-py3.8.egg/amset/tools/", line 103, in wave
    coeffs, gpoints = _wavefunction_vasp(
  File "/projects/anaconda3/lib/python3.8/site-packages/amset-0.4.15-py3.8.egg/amset/tools/", line 124, in _wavefunction_vasp
    wf = get_wavefunction(wavecar=wavecar, directory=directory, vasp_type=vasp_type)
  File "/projects/anaconda3/lib/python3.8/site-packages/amset-0.4.15-py3.8.egg/amset/wavefunction/", line 28, in get_wavefunction
    return Wavecar(wavecar, vasp_type=vasp_type)
  File "/projects/anaconda3/lib/python3.8/site-packages/pymatgen-2022.2.7-py3.8-linux-x86_64.egg/pymatgen/io/vasp/", line 4962, in __init__
    raise ValueError(
ValueError: Incorrect value of vasp_type given (std). Please open an issue if you are certain this WAVECAR was generated with the given vasp_type.

Hi @foster362 - how large is your WAVECAR file?

Large, 21 GB. However, I have successfully run “amset wave” on a 31GB WAVECAR file. The system giving me trouble has a more distorted unit cell; the angles broke from 90 (alpha=99.7738; beta=89.5719; gamma=81.2136) when achieving tight geometry convergence (EDIFFG=-0.0005). Maybe I will try optimizing the system again trying to maintain better symmetry.