Bonchk failed - ReaxFF with NEB

Hello everybody,

i am trying to use NEB with the following and the but i am getting the following error right after the NEB command:

System init for write_data …
ERROR on proc 0: step6-bondchk failed: i=60 end(i)=1529 str(i+1)=1525

Can you please help me find the error. Is this related to my final data ? Since minimization works fine after reading the

This error message usually indicates that your whole system or the part on one of the MPI ranks is undergoing a large change in the number of bond order interactions. This can be adjusted to some degree by using the “mincap” and “safezone” keywords. The regular reax/c pair style has a memory management that assumes that there is only a limited number of changes in the environment. As an alternative, you can try compiling the KOKKOS version of reax/c (for CPU), which replaces some of the heuristic based memory management routines with more robust versions.

Thank you axel but does kokkos have quickmin as a min_style ? How to use it with kokkos ? I am getting the following:
ERROR: Must use a Kokkos-enabled min style (e.g. min_style cg/kk) with Kokkos minimize (…/min.cpp:117)

Just for information. Using more processors per partition works. I switched from 8x2 to 2x8 and it is working fine

I am getting that error when i use multiple replicas. Using only 2 replicas is working but i do not know why. The documentation does not tell how to use quickmin with kokkos

Hello axel,
i think i did not reply to you directly. It is working with 2 replicas but everything over 2 replicas is not working. The documentation does not clarify how to use quickmin with kokkos. Is that even possible ? I cannot use the cg/kk style
Best regards

If it is not mentioned in the manual, then it is not available.

I had a quick look at your data and coordinate files. They look inconsistent. The data file is especially problematic because it has very high image flag counts. Since you are starting a new calculation, I suggest you first properly recenter your system and reset the image flags and then create the NEB coordinate file to be consistent with that.

The fact that your input does not crash with 2 replica is rather obvious: you won’t get “crazy” configurations with only 2 replica since there is no interpolation between the two sets of coordinates happening, so it doesn’t show that they are inconsistent.

thanks a lot Axel. I recentered my system by using topotools and voila NEB working on multiple partitions