“Bond atom missing in image check” error

Hello all,

I want to simulate the fracture of elastomers by mesoscopic method in lammps, which means there are only coordinates of the crosslinks contained in my data file. Chains between crosslinks are regarded as bonds (thus bonds are long, and I use a table file to define the energy and the force of the bonds). When I run the simulation, I get a "Bond atom missing in image check " error .
How can I resolve the problem?

Thanks in advance,


You have to make certain that your communication cutoff is large enough for your long bonds.
Usually, this is not a concern since for atomic systems, the non-bonded cutoff for building the neighbor lists is large enough and that enforces that the communication cutoff is large enough. But if the bonds can become longer than the cutoff for the non-bonded interactions, you have to make adjustments. Have a careful look at your log file. There may be warnings about this.

I have read the error message of lammps, which also shows this is because the pairwise cutoff is set too short. However, if I set the pairwise cutoff longer, the simulation will become unstable.

Thus I decided to turn off the pairwise interactions by using the command “neigh_modify” and “pair_style none”, but the error message is still “Bond atom missing in image check”. How can I deal with this?

Please re-read my response. The communication cutoff is a different thing than the pairwise (or neighbor list cutoff). It is just that the former is by default set to the latter. If you have no pair style then you must set the communication cutoff with comm_modify. There will be a warning to that effect in your log file.

With a long communication cutoff, your simulation will be slowed down due to excessive communication required to implement the domain decomposition parallelization. It won’t be as much though than when increasing the non-bonded (= neighbor list cutoff) since that will also blow up your memory consumption without using it). You can think about using a mix of MPI and OpenMP instead.

I already told you and you obviously haven’t tried it.