Bug: ruamel.yaml package not detected [SOLVED]

When following the atomate installation instructions we are asked to run a test script with the following code:

test.py:
from atomate.vasp.database import VaspCalcDb
x = VaspCalcDb.from_db_file(“db.json”)
x.reset()
print(“SUCCESS”)

upon running that code, I encountered the following error:

[email protected]:~/atomate-qchem/config> python test.py
Found many potential paths for FW_CONFIG_FILE: [’/global/u1/o/oac/atomate-qchem/config/FW_config.yaml’, ‘/global/homes/o/oac/atomate-qchem/config/FW_config.yaml’]
Choosing as default: /global/u1/o/oac/atomate-qchem/config/FW_config.yaml
Traceback (most recent call last):
File “test.py”, line 1, in
from atomate.vasp.database import VaspCalcDb
File “/global/u1/o/oac/codes/atomate/atomate/vasp/database.py”, line 24, in
from atomate.utils.database import CalcDb
File “/global/u1/o/oac/codes/atomate/atomate/utils/database.py”, line 18, in
from atomate.utils.utils import get_logger
File “/global/u1/o/oac/codes/atomate/atomate/utils/utils.py”, line 16, in
from fireworks import Workflow
File “/global/u1/o/oac/codes/fireworks/fireworks/init.py”, line 9, in
from fireworks.core.firework import FiretaskBase, FireTaskBase, Firework, Launch, Workflow,
File “/global/u1/o/oac/codes/fireworks/fireworks/core/firework.py”, line 30, in
from fireworks.core.fworker import FWorker
File “/global/u1/o/oac/codes/fireworks/fireworks/core/fworker.py”, line 14, in
from fireworks.utilities.fw_serializers import FWSerializable, recursive_serialize,
File “/global/u1/o/oac/codes/fireworks/fireworks/utilities/fw_serializers.py”, line 42, in
import ruamel.yaml as yaml
ModuleNotFoundError: No module named ‘ruamel’

From what I can tell, this is an extension of a known bug noted in the conda and pip issue trackers.

I am working on the NERSC system and using conda as my environment manager. I have tried pip installing atomate and fireworks as well as installing the most recent version from Git.

I solved the issue by changing every instance of ruamel.yaml to ruamel_yaml. However, I am not sure if that is a permanent fix or if it would have consequences for other users with different environments. Guidance for a more general fix would be appreciated.

EDIT: I solved this issue by installing my own version of python on NERSC rather than using the base packages.