Chemical potential for the use of gcmc

Dear Aidan,

I had found each chemical potential corresponding to a desired bulk composition. Then, I tried to run gcmc with the multicomponent system in nanopore instead bulk, with the chemical potential. However, it does not run and produce core.* file just before gcmc command so nothing related to gcmc shows up in log file. What does the core.* file means? I have change various parameters a lot but it did not make it. The nanopore configuration was what I have used with many different simulation and I also tried to run gcmc with individual component (pure component system) in the configuration as practices before trying to run multicomponents.

30Jul2016 Lammps is being used and I attached the log file. I need your advice.


log.lammps (9.39 KB)

I am glad to hear that you were able to get fix gcmc working for a multicomponent gas. The log file from the nanopore simulation tells me nothing, probably because it is incomplete. In order to capture any fatal error message generated by LAMMPS or the system, you should try to capture the screen output, either by running interactively, or by redirecting stdout to a file, or by using -screen option. You should also use ‘-echo both’ to see the input commands as they are processed.

You should also update to the most recent version of LAMMPS.

If you still can’t figure out the problem, I suggest posting the smallest possible non-working example, with input script, data file, and any other files needed.


Thank you. I will try with your advice.

By the way, what is the smallest possible non-working example ? I cannot find out any information about it.


It means you stripping down your complex input
script to the smallest possible example of
a script that doesn’t work,
and posting that script so someone else can
easily re-produce the problem.