Compiling LAMMPS with CUDA -- CUDA_ARCH

please always reply to the mailing list and not only individual people. thanks.

Thanks, that worked, but I ran into another one: "../pppm_cuda.cpp:1290:5:
error: ‘PPPM’ has not been declared PPPM::poisson(eflag,vflag);"

that one should also be straightforward to fix with a one-line change.
again, this is due to a small change in the API due to an added

diff --git a/src/USER-CUDA/pppm_cuda.cpp b/src/USER-CUDA/pppm_cuda.cpp
index 2a2973c..61b6cb7 100644
--- a/src/USER-CUDA/pppm_cuda.cpp
+++ b/src/USER-CUDA/pppm_cuda.cpp
@@ -1290,7 +1290,7 @@ void PPPMCuda::poisson(int eflag, int vflag)

#ifndef FFT_CUFFT
- PPPM::poisson(eflag,vflag);
+ PPPMOld::poisson();
#ifdef FFT_CUFFT

The reason I want to use the user-cuda package is that is has an accelerated
gran/hooke pair style, which is very similar to a custom pair style of mine.
If I could get things to work, I could see what the performance improvements
are for that style and if it is worth the trouble to accelerate my own pair

for that you don't need the KSPACE package and should simply uninstall
that. all accelerator package are supposed to adapt themselves to only
try to add accelerated styles that are provided as non-accelerated