converting unwrapped dump files to wrapped dump file with rerun command?

nobody will look into issues with outdated versions. bugfixes will
only be applied to the latest version, so you first need to update and
test with that version.



so you first need to update and test with that version.\

I have just installed recent lammps version (28June2014) and it seems that the same problem is still there: Using the input script (below), the rerun command generates a single-time frame wrapped dump file from an unwrapped dump file. All time frames t>0 are replaced by the t=0 frame...
I might be missing something trivial. Any help would be appreciated. Thanks


It does not work: I got a dump_rerun.lammpstj file but all timesteps are copies of the first time step, t=0. The >timestep labels for t>0 are correct in the dump_rerun file but the coordinates for t>0 are the coordinates of the first >frame. That means if I visualise the system with VMD, nothing moves.

Your rerun command specifies “replace no”, which means the coords for any atom ID in the dump
file that already exists in your setup simulation, will not be overwritten. I’m guessing
that causes the behavior your are seeing.

You also don’t need the “wrapped no” option. As the read_dump doc
page explains, it is ignored unless you are assigning your own labels to
columns in the dump file that you want to read. Otherwise LAMMPS knows

how to do the unwrapping. You probably also don’t need the purge and add
options unless you are doing something more complicated than you explained.


Dear Steve,

Thank you for your kind response. Obviously, I misunderstood the “replace” command: I have removed replace no option, and now rerun generates unwrapped coordinates as it should do.

For the record, I get several “half of periodic box length” and “Inconsistent image flags” warnings, but apart from those, everything is OK and intact, i.e., no unusual bondings, etc., as mentioned before in the discussion.

Thanks again for your help!