Error: All pair coeffs are not set

Hi Altruists,
In merging the data files for decane and water, I am seeing this error. I did simulation on decane and water separately, and there was no problem. But, during merging two data files, a problem is occurred with the system. Would you like to say what I am doing wrong here?
Sincerely,
Akash Talapatra
decane.data (143.4 KB)
water.data (721.4 KB)
new.txt (1.6 KB)

https://docs.lammps.org/Errors.html

Actually, I did simulation on the decane initially. There was no problem or error shown. Then I used write_data to have the equilibrium data after npt simulation. Everthing was found good. The error has been shown in case of merging with water data file.

What has that to do with:

  • the fact that the error message is pretty much self-explanatory?
  • the fact that there is a detailed listing of error messages and further explanations in the LAMMPS manual?
  • the fact that there are instructions in the LAMMPS manual what you should do to resolve errors before posting a message to the forum?

The only conclusion that would be consistent with these facts is not very flattering, so I won’t draw it in public.

1 Like

try making a list
and checking it twice
to see which i j pair
you didn’t specify
then all pair coeffs will be foooooound

you gotta read the errors
and figure out the crash
imagine if LAMMPS ran and ran
and left you terabytes of trash!

2 Likes

Thank you sir for your help. Actually, I cross check the pair_coeffs multiple times for individual simulation on decane and water, and didn’t find any problem to run on them. Because, the coeffs for carbon and hydrogen were provided my moltemplate itself for opls-aa forcefiled. This problem is only visible in case of creating interface. I couldn’t find any space for providing more pair coeffs, since for carbon and hydrogen, all of the pair_coeffs were provided.

LAMMPS would not throw an error if the pair coeff data was complete. Thus regardless of how many times you claim, that you did everything correctly, and entered everything, there must be an error somewhere and presumably in the way how you combine the two data files.

The info coeffs command tells you which coeffs are (explicitly) set. That should give you a hint where the problem is.

Thank you sir. I solved the problem. Your suggestion was really helpful.