Error during installing LAMMPS

Dear LAMMPS’s Users
I was installing lammps17Aug2019 in a cluster machine using mpi While making mpi I got this msg:

In file included from …/pointers.h:24:0,
from …/read_dump.h:26,
from …/read_dump.cpp:22:
…/read_dump.cpp: In member function ‘void LAMMPS_NS::ReadDump::process_atoms()’:
…/lmptype.h:86:19: error: ‘INT64_MAX’ was not declared in this scope
…/read_dump.cpp:1063:45: note: in expansion of macro ‘MAXBIGINT’
if (atom->natoms < 0 || atom->natoms >= MAXBIGINT)
make[1]: *** [read_dump.o] Error 1-----------

can anyone help me to resolve this problem?

note: the make serial works very well
Best regards.

Have you tried the last stable, or feature version of LAMMPS? It is generally a good idea to use the latest version.
Also, which commands did you use to compile LAMMPS?

There is no such version. There are 17Aug2017 or 7Aug2019.

What is the OS, the compiler, the architecture, the MPI library and version?

Thank you very much for your quick reply
Yes, the right version is 7 Aug 2019.
I need to work on the old versions of lammps
Indeed… the problem was solved when we changed the version to 14May2016.
Best regards.

You are using versions of LAMMPS with known bugs.