ERROR on proc 0: Support for writing movies not included (src/dump_movie.cpp:60)

Dear all, I’m very new to lammps and have no previous experience with linux.
The lammps version I’m used is LAMMPS (2 Aug 2023), my platform is MacOS13.2
I’m trying to follow the lammps workshop 2023, Virtual LAMMPS Workshop and Symposium 2023
There’s an already compiled lammps for macOS to download in the tutorial but I choose to download the lammps source with git on the lammps website. I follow the steps and run in the build directory
cmake -C …/cmake/presets/most.cmake …/cmake
cmake --build .
make install
then I proceed to run the basic_exercise in the tutorial by
~/mylammps/build/lmp -in in.friction
and I get following error
ERROR on proc 0: Support for writing movies not included (src/dump_movie.cpp:60)

Last command: run 20000

MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD

with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.

You may or may not see output from other processes, depending on

exactly when Open MPI kills them.

How do I solve this error? Does it relate to my compilation? I already tried recompile and run make clean in between but the same error still appears. Thank you in advance for your help!

Yes. You don’t have a viable FFMpeg executable installed but that is required to create movies with the dump movie command. CMake tries to detect this and will set the option -D WITH_FFMPEG accordingly.

Thank you very much akohlmey! I add to cmake option and recompile. It works now.

Hi, Prof. Kohlmeyer.
I encountered the same problem as mentioned in this thread. I did exactly the same thing as the other user sakusakusakuma. Then I install the FFMpeg executable. After checking with ffmpeg --version , I am sure that ffmpeg is installed. Then I recompile again. Running the example gave me the same error.
I also tried cmake -D FFMPEG_Executable=the path in my own computer, and recompile. It gave the same error.

cmake -C …/cmake/presets/most.cmake …/cmake
cmake -D FFMPEG_Executable = /usr/.local/bin/ffmpeg
cmake --build .

I did the following in details.

This problem also raise for the png, jpeg output on my lammps.
Do you have any suggestion on this situation?

I appreciate any help and suggestion from you.

Just follow the documentation: 3.5. Optional build settings — LAMMPS documentation

This is pretty much what i did after following the tutorial 3.5.

cmake -C …/cmake/presets/most.cmake -D WITH_FFMPEG=yes …/cmake
cmake -D FFMPEG_EXECUTABLE = /usr/.local/bin/ffmpeg
cmake --build .
cmake --install .

However, it doesn’t fix the movie output error.
I am not sure which step is missing here.

This line will create an error and thus have no effect. Check out the CMake documentation.

cmake -D FFMPEG_EXECUTABLE = /usr/bin/ffmpeg ../cmake

Running this in the terminal doesn’t throw an error though. I also check the CMakeCache.txt. There is an entry about the path in CMakeCache

//Path to a program

I’m really sorry that forgetting to include …/cmake in the previous reply.

Thank you for your reply and information. Someone helped me correctly set up the stuff now with make.