error running example gcmc_co2

during compiling obtain this error

[[email protected]…6889… src]# make g++_openmpi
/bin/sh: python-config: command not found
make[1]: Entering directory /opt/lammps-31Mar17/src/Obj_g++_openmpi' make[1]: Leaving directory /opt/lammps-31Mar17/src/Obj_g++_openmpi’
/bin/sh: python-config: command not found
make[1]: Entering directory /opt/lammps-31Mar17/src/Obj_g++_openmpi' mpicxx -g -O3 -DLAMMPS_GZIP -I../../lib/reax -DLMP_PYTHON -I../../lib/poems -I../../lib/mscg/includelink -DLMP_MPIIO -I../../lib/meam -DLMP_KOKKOS -DMPICH_SKIP_MPICXX -DOMPI_SKIP_MPICXX=1 -I./ -I../../lib/kokkos/core/src -I../../lib/kokkos/containers/src -I../../lib/kokkos/algorithms/src --std=c++11 -fopenmp -c ../angle_charmm.cpp cc1plus: error: unrecognized command line option "-std=c++11" make[1]: *** [angle_charmm.o] Error 1 make[1]: Leaving directory /opt/lammps-31Mar17/src/Obj_g++_openmpi’
make: *** [g++_openmpi] Error 2

Al

If you include the KOKKOS package then you need to use a c++11 compatible compiler, i.e. gcc 4.7.2 or higher.

Stan

Hi,

now I’m tring install lammps with g++ and openmpi

this is my makefile

compiler/linker settings

specify flags and libraries needed for your compiler

CC = g++
CCFLAGS = -g -O3
SHFLAGS = -fPIC
DEPFLAGS = -M

LINK = g++
LINKFLAGS = -g -O3
LIB =
SIZE = size

ARCHIVE = ar
ARFLAGS = -rc
SHLIBFLAGS = -shared

---------------------------------------------------------------------

LAMMPS-specific settings, all OPTIONAL

specify settings for LAMMPS features you will use

if you change any -D setting, do full re-compile after “make clean”

LAMMPS ifdef settings

see possible settings in Section 2.2 (step 4) of manual

LMP_INC = -DLAMMPS_GZIP -DLAMMPS_MEMALIGN=64

MPI library

see discussion in Section 2.2 (step 5) of manual

MPI wrapper compiler/linker can provide this info

can point to dummy MPI library in src/STUBS as in Makefile.serial

use -D MPICH and OMPI settings in INC to avoid C++ lib conflicts

INC = path for mpi.h, MPI compiler settings

PATH = path for MPI library

LIB = name of MPI library

MPI_INC = -I/opt/openmpi-1.6.3/include -pthread
MPI_PATH = -L/opt/openmpi-1.6.3/lib
MPI_LIB = -lmpi

FFT library

see discussion in Section 2.2 (step 6) of manual

can be left blank to use provided KISS FFT library

INC = -DFFT setting, e.g. -DFFT_FFTW, FFT compiler settings

PATH = path for FFT library

LIB = name of FFT library

FFT_INC = -I/usr/local/fftw-3.3.6-pl2/include -DFFT_FFTW3
FFT_PATH = -L/usr/local/fftw-3.3.6-pl2/lib
FFT_LIB = -lfftw3f

Is there a reason you can’t just use the “mpicxx” wrapper instead of “g++”?