Error: Unknown atom style


I am trying to run USER-SMD examples currently.
It requires ‘atom_style smd’.

However, when I run the example file, I get the error: ‘Unknown atom style’.
Similar is the error when I run USER-SPH examples with ‘atom_style meso’.

I have installed both packages, USER-SMD and USER-SPH. It installed properly without any errors.
I also did the ‘make mpi’ after installing these packages. There was no error.

I checked the atom_style type available on my machine. Here’s the result:

List of style options included in this LAMMPS executable

  • Atom styles:

angle atomic body bond charge

dipole ellipsoid full hybrid line

molecular peri sphere template tri

As shown above, the atom_style ‘meso’ and ‘smd’ is not in the list above.

Can anyone please tell me why do these two atome_styles are not shown in the list above?

Thank you for the help.


It seems the packages were not installed properly.

Have you checked “make package-status” in the src directory prior to “make mpi”?
If both packages are installed correctly, the status should indicate “yes”.