ERROR: Unknown command: download molecule then make import ask molecule txt (Forgot to uncomment line, fixed now)

Hi all,

I’m using LAMMPS (2 Aug 2023 - Update 3) on a Macbook Air with an M2 silicon chip.
I ran into this error when working on my LAMMPS code. I was trying to introduce some SiO2 molecules to my H2O bulk. I was using the following lines of code:

molecule myMolecule SiO2mol.txt

create_atoms 0 random 10 12347 add_atoms mol myMolecule 12347 overlap 0.2 maxtry 50

However, when I ran it I got the ERROR: Unknown command: download molecule then make import ask molecule txt. Here is what my molecule .txt file looks like:

LAMMPS data file written by OVITO Basic 3.10.6

3 atoms
2 bonds
2 atom types
1 bond types

-2.5 1.215 xlo xhi
0.0 4.656515 ylo yhi
1.5 5.3 zlo zhi


1 15.9994 # O
2 28.085501 # Si

Atoms # full

2 1 2 0.0 -1.152 1.996 3.621
4 1 1 0.0 0.307 1.76 4.263
6 1 1 0.0 -1.087 3.111 2.453


1 1 2 6
2 1 2 4

Any ideas in resolving this error will be appreciated. Thank you in advance, Vikentiy

Crisis averted. I looked through the documentation and found a sample file at this link: molecule command — LAMMPS documentation.

My file was formatted wrongly.

I apologise for wasting everybodies, but if this error were to occur to anyone else you know what to do now.


The error you reported cannot be created by the molecule command. It looks more like you removed the pound sign (#) from a comment in the input file.

Thank you. You are absolutely right, I was taking notes and forgot to comment them out before running the simulation. Sorry for wasting your time