Error with Reaxff (Segmentation fault: address not mapped to object at address 0x17399240)

Dear LAMMPS Users:

I’m trying to use reaxff (LAMMPS version: 23 Jun 2022) to simulate the process of high velocity hydrogen being oxidized in air. 600 H2 was placed at the left side of the box and air occupies the remaining space. All H2 molecule has a initial speed of 0.03Å/fs to the right. The job failed after 37600 steps. It seems that the job fails the moment when the H2 molecules come into contact with air, the error message shows:

[amd28:88632:0:88632] Caught signal 11 (Segmentation fault: address not mapped to object at address 0x166b1a80)
==== backtrace (tid:  88632) ====
 0 0x00000000005b41f8 Num_Entries()  /share/home/lijun/softwarez/lammps/src/REAXFF/reaxff_api.h:109
 1 0x00000000005b41f8 Validate_Lists()  /share/home/lijun/softwarez/lammps/src/REAXFF/reaxff_forces.cpp:112
 2 0x00000000005b41f8 Init_Forces_noQEq()  /share/home/lijun/softwarez/lammps/src/REAXFF/reaxff_forces.cpp:248
 3 0x00000000005b41f8 ReaxFF::Compute_Forces()  /share/home/lijun/softwarez/lammps/src/REAXFF/reaxff_forces.cpp:374
 4 0x00000000005a80e7 LAMMPS_NS::PairReaxFF::compute()  /share/home/lijun/softwarez/lammps/src/REAXFF/pair_reaxff.cpp:482
 5 0x0000000000566c2d LAMMPS_NS::Verlet::run()  /share/home/lijun/softwarez/lammps/src/verlet.cpp:316
 6 0x000000000050fe89 LAMMPS_NS::Run::command()  /share/home/lijun/softwarez/lammps/src/run.cpp:176
 7 0x0000000000427cdd LAMMPS_NS::Input::execute_command()  /share/home/lijun/softwarez/lammps/src/input.cpp:811
 8 0x00000000004286fe LAMMPS_NS::Input::file()  /share/home/lijun/softwarez/lammps/src/input.cpp:278
 9 0x000000000040a5f8 main()  /share/home/lijun/softwarez/lammps/src/main.cpp:98
10 0x0000000000022555 __libc_start_main()  ???:0
11 0x000000000040c0ee _start()  ???:0

my input file is:

# input file
units			real
dimension		3
processors		* * *
boundary		f f f 
box tilt 		large

# read data
atom_style		full
group			react type 1 

# potential
pair_style		reaxff NULL
pair_coeff	 	* * ffield.reax.035.CHOSFClN H N O

# md parameters
neighbor		2 bin
neigh_modify	every 10 delay 0 check yes	
fix             	q all qeq/reax 1 0.0 10.0 1e-6 reaxff

# outputs
thermo		100
thermo_style	custom step temp pe press density cpu cpuremain
dump			2 all custom 100 md.lammpstrj id type x y z

# initialize
minimize 		1.0e-4 1.0e-6 100 1000
velocity 		react set 0.03 NULL NULL units box

# run
fix			3 all nve
timestep		0.1	
run			10000000
unfix			3

I tried to run the same job on intel xeon cpu and got the same result.
I’m wondering if the error is caused by an unreasonable input file or wrong installation of lammps.
Any advice on fixing the problem is welcome!

This has likely a similar origin as in your other post (Get stuck with reaxff)
and thus similar solutions need to be used.

1 Like

Thank you for your kind suggestion, I find it very reasonable.

Highly recommend using the Kokkos version of ReaxFF, even on CPUs.

Thank you for your kind reply, I’m going to recompile my lammps with kokkos package.