[EXTERNAL] Re: Lammps KOKKOS Compile Error

I tried with the 10 Feb 2015 version and couldn't reproduce the error. What compiler are you using?

I have been using the GCC toolchain. I tried using the Intel version listed below, but I get this error:

nvcc warning : The -c++11 flag is not supported with the configured host compiler. Flag will be ignored.

I am able to compile C++11 programs with this version of Intel compilers, so I am not sure what’s going on there (maybe because you specified --std=c++11 instead of -std=c++11?).

I’ve been using OpenMPI 1.8.4 with GCC, and I would be using Intel MPI if I ever could get Intel to work.

More version information below.

$ nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2014 NVIDIA Corporation
Built on Thu_Jul_17_21:41:27_CDT_2014
Cuda compilation tools, release 6.5, V6.5.12

$ g++ --version
g++ (GCC) 4.8.2
Copyright (C) 2013 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

$ icpc --version
icpc (ICC) 14.0.2 20140120
Copyright (C) 1985-2014 Intel Corporation. All rights reserved.

Cuda only recently (7.0) added support for the C++11 standard.
You're using 6.5. :wink:

[ ]'s

It added support for C++11 in the device code — it worked previously with host code. Is C++11 used in the LAMMPS GPU code for KOKKOS?

I’m in the process of upgrading to CUDA 7.0 anyway because it supports newer compiler versions.

I have upgraded to:

$ nvcc --version
Cuda compilation tools, release 7.0, V7.0.27

$ icpc --version
icpc (ICC) 15.0.0 20140723

$ g++ --version
g++ (GCC) 4.9.2

Intel MPI version
OpenMPI version 1.8.4

And am still getting all of the errors that have been discussed in this thread.

Can I get more help on installing kokkos_cuda without MPI? I was never able to figure out how to do that.