Fix bond/react cannot break bonds in a small molecule

Hi there,

I’m having some problems with this command fix bond/react.I will describe my problem in as much detail as possible. (My input file is at the end of the problem description)

As shown in the picture is my structure file. Numbered spheres are written into the molecule template file. The meaning of the specific numbers is as follows:T for atom type, I for particle ID in the data file, the last number for atom order in molecule template. For example, T1 I6-14 presents the atom is type 1, and its particle ID is 16, and its atom order in molecule template is 14.

I tried to delete bond between in T3 I11-2 and T4 I13-5. But I cannot realize that.

Any help on the errors would be greatly appreciated! I guess my issues are Coords
are not correct, but I cannot fix them out.



data_S1_2.gro2lam (6.0 KB)
in.lmp (948 Bytes) (174 Bytes)
rxn1_stp1_post.data_template (1.2 KB)
rxn1_stp1_pre.data_template (1.5 KB)

If your molecule template contains the entire molecule, it should not have any edge atoms (i.e., no EdgeIDs section). Edge atoms are those that connect to the rest of a larger molecule in the simulation.

1 Like

Upon closer look, I see that you should have edge atoms. However, you are listing the wrong atoms IDs in your EdgeID sections (looks like they should be 13 and 14). It looks like you also have some incorrect atom types in your pre-reaction template, as compared to your data file.

Thank you for your reply. I tried to use atoms T1 I6-14 and T1 I3-13 as EdgeIDs for the simulation, but it still didn’t work.

In this example, I want to achieve the breaking of a chemical bond between two atom pairs ①T3 I11-2 and T4 I13-5T3 I12-6 and T6 I15-8 (Sorry for missing an atomic pair in the previous problem description). To ensure the integrity of bond-related parameters around bond-breaking atoms, I have tried to include as few atoms as possible in the molecule template.

I’m wondering if maybe my molecular structure is too complex and the Coords section changed at the beginning of the simulation. In this way, the reaction doesn’t trigger at all.

As I mentioned in my previous post, you also have an incorrect atom type in your pre-reaction template. Atom 12 should be changed to type 11.

Now it finally works. This problem has been bugging me for a week.

Thank you for your time and thank you very much for your help.:smiley:

Great. Also, to clarify one of your earlier comments, atomic coordinates do not affect if the reaction occurs unless you are using some advanced reaction constraints, such as the RMSD constraint.

1 Like

I see. I still need to learn more about the fix bond/react command.

Thanks again for your guidance. :grin: