GPU/CPU ratio


I am running lammps in a cluster which has 8 GPU's and 12 CPU's in a
node. I am not able to run lammps with the gpu (not cuda) accelerator
when the ratio of GPU to CPU is less than 1 (more CPU cores than
physical GPUs). The GPUs are m2050's and are running in "Compute Mode:
Exclusive_Process" with driver version 285.05.09. I just want to
confirm if it has something to do with the "Compute Mode" and I can
ask the administrator to give me the option to change modes.



Mike can provide details here.

The GPU package is able to assign multiple CPUs to each GPU.
However, I think you need to have an integer # of CPUs per GPU,
not 1.5.


Hey Jan-Michael,

When the compute mode is not "default", multiple MPI processes cannot
share a GPU. Should be no problem with your case though. In the "package"
line in your input, make sure that the second number for the GPU id is
high enough so that it uses the same number of GPUs as MPI processes. If
you still have a problem, send me the error and I will look into it. - Mike


This is exactly what I observe and I have been running it this way.