Help:LAMMPS GPU

hello, I want to use LAMMPS with GPU on ubuntu 2020.04, but I am having some problems.

Ubuntu Desktop 2020.04
LAMMPS: the latest (by git clone)

CUDA 10.2

image.png

I built LAMMPS as follows:

  1. src/
    make lib-gpu args="-b" -j

image.png

  1. build/
    cmake -D PKG_MANYBODY=yes -D BUILD_OMP=yes -D PKG_GPU=on -D GPU_API=cuda …/cmake/

image.png

  1. build/
    make -j
  2. build/
    make install -j

1-4 is successful. but when I use LAMMPS with GPU, there is some error (“lmp -in lmp.in” is OK)

image.png

thank you

Hi Yuh,

Can you see what is the result if you make ./nvc_get_devices in ~/lammps/lib/gpu?

Regards

El El lun, 8 de junio de 2020 a la(s) 16:48, yuh ldr <[email protected]…24…> escribió:

image.png

image.png

image.png

image.png

please check with nvc_get_devices (in the build folder) what your GPU hardware platform is. most likely not sm_50.
and try to configure/compile with setting that for the GPU_ARCH variable (sm_50 is the default).
we are trying to build “fat” binaries, but i suspect some objects are escaping that process currently.

image.png

image.png

image.png

image.png

build/nvc_get_devices,but I don’t know which GPU_ARCH I should choose

image.png

Axel Kohlmeyer <[email protected]> 于2020年6月9日周二 上午4:03写道:

image.png

image.png

image.png

image.png

you have “Compute capability 6.1” that means you should set:

-D GPU_ARCH=sm_61

please see the manual: https://lammps.sandia.gov/doc/Build_extras.html#gpu

also, if you use CMake, you don’t need to do anything in lib/gpu (which is also explained in the manual).

axel.

image.png

image.png

image.png

image.png

image.png

sorry, cmake … 、make -j 、make install -j, there is still the same error.
image.png

image.png

image.png

Axel Kohlmeyer <[email protected]> 于2020年6月9日周二 上午4:47写道:

image.png

image.png

image.png

image.png

image.png