How to access python tools files (e.g. if lammps is installed using apt-get

I have installed lammps in a remote machine through apt-get.

Following were the commands:

$ sudo add-apt-repository ppa:gladky-anton/lammps
$ sudo add-apt-repository ppa:openkim/latest
$ sudo apt-get update
$ sudo apt-get install lammps-stable

lmp_stable is the executable. It works fine. However I can not find the python tools like, etc.
So in order to use them I copied and pizza folder from my local machine and put it in the remote machine. Then I tried python <location>/ <log file from lammps <thermo keyword 1- Step> <thermo keyword 2- Temp> and it did not work. Error was

  File "/home/ubuntu/multiscale/bin/", line 12, in <module>
    path = os.environ["LAMMPS_PYTHON_TOOLS"]
  File "/usr/lib/python2.7/", line 40, in __getitem__
    raise KeyError(key)

Then I tried to make the environment variable LAMMPS_PYTHON_TOOLS=<location of python files>/pizza/

It still shows same error.

So my question is, how to access the tools/python/ files when I install lammps using apt-get and in case I copy the files from somewhere else, then how to make it work?

This is a question you have to ask the person packaging the LAMMPS binaries you are using. This is not done by the LAMMPS developers. We only mention the repository as a courtesy and convenience. As with other packaging of binaries, what files are included and how they are installed is a choice of the individual people managing the packaging.

That is supposed to happen, because you didn’t follow the instructions.

Impossible to say from remote what is the cause. The most likely explanation would be that you made some typo somewhere or didn’t properly export the variable. There is not more to say and explain than what is in the tools/python/README file. The rest is a question of Python skills.

It worked. Thanks for your help.