How to create a region to include the surface-layer atoms?

20Apr11 vision

My Region definition like this:
variable wall_wid equal (1.5+${epsl})a # a is lattice constant<br>.<br>.<br>.<br>read_data bcc-iron.dat # difine 20X20X100 bcc lattices, origin (0,0,0)<br><br>region wall block 0.0 {lenx} 0.0 {leny} INF {wall_wid} units box

# settings options

set region wall type 2

group surface type 2
group material type 1
dump 1 material cfg 200 confg/dump.snap.
.cfg id type xs ys zs vx vy vz fx fy fz

dump_modify 1 first yes element Fe Cu
As I watch the first dump file, i.e. dump.snap.0.cfg, the firs atom-layer is belong material !!! Not what I expect to belong region surface.

And I have tried

region wall block 0.0 {lenx} 0.0 {leny} 0.0 {wall_wid} units box<br><br>and<br><br>region wall block 0.0 {lenx} 0.0 {leny} -0.05 {wall_wid} units box

respectively, but it does not have any changes.

What should I do if I want to include the first layer atoms into region surface???

I am urgently needing your help. Any responds will be appreciated. Thanks in advance.


I don’t know the geometry of your system,
but I suggest you debug by taking it one
command at a time and verifying that the
region geometry and atom groups contain
exactly what you expect. You can also
look at the dump_modify region option
and at making regions dynamic (options
on region command) to track moving atoms.