How to install Kokkos in a correct way?

Hi all!

I’m interested in simulating a system including Cu, C, H and Ar atoms, using parameters from eam, airebo, and LJ, and also with Reax/c, on my GPU.

As I understand, I can’t use the GPU package for AIREBO or Reax/c, so I should install Kokkos, but I’m a bit afraid of breaking my current drivers installation in the process. Could you give us some suggestions to accomplish it?

I attach the protocol of my current installation of LAMMPS and the information of my nvidia GTX 1050-MaxQ.

sudo apt install ocl-icd-opencl-dev
sudo apt-get install openmpi-bin
sudo apt-get install cmake
cd lammps
mkdir build; cd build
cmake …/cmake
cmake -C …/cmake/presets/minimal.cmake .
cmake -C …/cmake/presets/kokkos-cuda.cmake .
cmake -D BUILD_MPI=yes .
cmake -D PKG_USER-REAXC=yes .
cmake -D PKG_GPU=yes .
cmake -D PKG_MANYBODY=yes .
cmake -D PKG_KOKKOS=yes .
cmake --build .
make install

Thanks a lot!


This returned when I executed cmake -C …/cmake/presets/kokkos-cuda.cmake .

Summary

cmake -C …/cmake/presets/kokkos-cuda.cmake .
loading initial cache file …/cmake/presets/kokkos-cuda.cmake
– Running check for auto-generated files from make-based build system
– Found OpenMP_CXX: -fopenmp
– Found OpenMP: TRUE
– Looking for C++ include omp.h
– Looking for C++ include omp.h - found
– Checking for module ‘fftw3’
– No package ‘fftw3’ found

– ****************** Kokkos Settings ******************
– Execution Spaces
– Device Parallel: None
– Host Parallel: None
– Host Serial: Serial

– Architectures:
– None

– Enabled options
– KOKKOS_ENABLE_SERIAL
– KOKKOS_ENABLE_LIBRT
– KOKKOS_ENABLE_PROFILING
– KOKKOS_ENABLE_DEPRECATED_CODE

– Final kokkos settings variable:
– env;KOKKOS_CMAKE=yes;KOKKOS_SRC_PATH=/mnt/respaldos/executables/lammps-3Mar20/lib/kokkos;KOKKOS_PATH=/mnt/respaldos/executables/lammps-3Mar20/lib/kokkos;KOKKOS_INSTALL_PATH=/home/g00/.local;KOKKOS_ARCH=None;KOKKOS_DEVICES=Serial;KOKKOS_DEBUG=no;KOKKOS_OPTIONS=disable_dualview_modify_check;KOKKOS_USE_TPLS=librt
– *****************************************************

– Submodule build
– The project name is: Kokkos
– Generating style_angle.h…
– Generating style_atom.h…
– Generating style_body.h…
– Generating style_bond.h…
– Generating style_command.h…
– Generating style_compute.h…
– Generating style_dihedral.h…
– Generating style_dump.h…
– Generating style_fix.h…
– Generating style_improper.h…
– Generating style_integrate.h…
– Generating style_kspace.h…
– Generating style_minimize.h…
– Generating style_nbin.h…
– Generating style_npair.h…
– Generating style_nstencil.h…
– Generating style_ntopo.h…
– Generating style_pair.h…
– Generating style_reader.h…
– Generating style_region.h…
– Generating packages_angle.h…
– Generating packages_atom.h…
– Generating packages_body.h…
– Generating packages_bond.h…
– Generating packages_command.h…
– Generating packages_compute.h…
– Generating packages_dihedral.h…
– Generating packages_dump.h…
– Generating packages_fix.h…
– Generating packages_improper.h…
– Generating packages_integrate.h…
– Generating packages_kspace.h…
– Generating packages_minimize.h…
– Generating packages_nbin.h…
– Generating packages_npair.h…
– Generating packages_nstencil.h…
– Generating packages_ntopo.h…
– Generating packages_pair.h…
– Generating packages_reader.h…
– Generating packages_region.h…
– Generating lmpinstalledpkgs.h…
– Building package: KSPACE
– Building package: MANYBODY
– Building package: MOLECULE
– Building package: RIGID
– Building package: KOKKOS
– The following tools and libraries have been found and configured:

  • Git
  • MPI
  • OpenMP
  • JPEG
  • PNG
  • ZLIB
  • PkgConfig

– <<< Build configuration >>>
Build type RelWithDebInfo
Install path /home/g00/.local
Compilers and Flags:
C++ Compiler /usr/bin/c++
Type GNU
Version 9.3.0
C++ Flags -fopenmp -O2 -g -DNDEBUG
Defines LAMMPS_SMALLBIG;LAMMPS_MEMALIGN=64;LAMMPS_JPEG;LAMMPS_PNG;LAMMPS_GZIP;LAMMPS_FFMPEG;FFT_KISS;LMP_KOKKOS
– Static library flags:
– Link libraries: /usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi_cxx.so;/usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi.so;/usr/lib/x86_64-linux-gnu/libjpeg.so;/usr/lib/x86_64-linux-gnu/libpng.so;/usr/lib/x86_64-linux-gnu/libz.so;m;kokkos
– Using MPI with headers in /usr/lib/x86_64-linux-gnu/openmpi/include/openmpi;/usr/lib/x86_64-linux-gnu/openmpi/include and /usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi_cxx.so;/usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi.so
– Kokkos Arch: NOT_SET
– Using KISS as primary FFT library
– Using double precision FFTs
– Using non-threaded FFTs
– Kokkos FFT: KISS
– Configuring done
You have changed variables that require your cache to be deleted.
Configure will be re-run and you may have to reset some variables.
The following variables have changed:
CMAKE_CXX_COMPILER= /mnt/respaldos/executables/lammps-3Mar20/lib/kokkos/bin/nvcc_wrapper
CMAKE_CXX_COMPILER= /mnt/respaldos/executables/lammps-3Mar20/lib/kokkos/bin/nvcc_wrapper

– The CXX compiler identification is unknown
– Check for working CXX compiler: /mnt/respaldos/executables/lammps-3Mar20/lib/kokkos/bin/nvcc_wrapper
– Check for working CXX compiler: /mnt/respaldos/executables/lammps-3Mar20/lib/kokkos/bin/nvcc_wrapper – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - failed
– Found Git: /usr/bin/git (found version “2.25.1”)
– Running check for auto-generated files from make-based build system
CMake Error at CMakeLists.txt:54 (if):
if given arguments:

"STREQUAL" "Intel"

Unknown arguments specified

– Configuring incomplete, errors occurred!

Hopefully you do not want to use all of those pair styles at the same time. That will likely be a disaster (regardless of whether you use the GPU or not). Using pair style hybrid only makes sense in general, when you have well separated subsystems for each sub-style and are not very interested in the interactions between those. E.g. when doing nano-machining you basically just want to push atoms of the substrate around by the shape of the tool and mostly need the repulsion to give a meaningful volume. On the other hand, when studying adsorption or catalysis or clustering etc. then you want all interaction particles to have consistent interactions.

  1. there is no GPU accelerated version of AIREBO. full stop.
  2. ReaxFF has GPU acceleration only via KOKKOS.
  3. When using ReaxFF it is a particularly bad idea to try using a hybrid pair style.
  4. There is no problem to compile both the GPU package and the KOKKOS package at the same time, you just cannot use them both at the same time.
  5. Building applications like LAMMPS has no impact on drivers.

The default setting for the GPU architecture in the kokkos-cuda.cmake preset file is for the Maxwell 5.0 architecture, while your GPU requires the Pascal6.1 architecture. For that you need to add the following two settings to your CMake configuration:

-DKokkos_ARCH_MAXWELL50=no
-DKokkos_ARCH_PASCAL61=yes

More details on this are in the manual: 3.7. Packages with extra build options — LAMMPS documentation
You may also want to enable multi-threading with OpenMP, since in most cases it is better to not have multiple MPI ranks attached to the same GPU.

To compile the GPU package for CUDA (instead of OpenCL) you would need to add

-DGPU_API=CUDA
-DGPU_ARCH=sm_61

While for the KOKKOS package selecting the correct GPU architecture is crucial, the GPU package will try to compile “fat” GPU kernels, that would run on any GPU supported by the CUDA toolkit in use. When using OpenCL the kernels are embedded without any platform specific translation which will happen at runtime, but - especially for LAMMPS versions older than 10 March 2021 the hardware specific kernel optimizations are not very effective. While there are still some pending issues (that large update in the 10 March 2021 version had some ripples that took a while sorting out), the performance of OpenCL has much improved and is - with the NEO Intel OpenCL runtime - also very effective and fast on Intel HD graphics GPUs included in Intel CPUs (from the 7th gen core architecture onward, IIRC). I have an i3-7100U CPU in my home office with a HD Graphics 620 GPU and that gets good GPU acceleration with single, mixed, and double precision using OpenCL, which is quite impressive for such a “wimpy” CPU.

More details on compiling the GPU package are in the manual: 3.7. Packages with extra build options — LAMMPS documentation

You have to keep in mind that your GPU is a low power consumption optimized version of a lower mid-range consumer GPU, so there is not too much acceleration to be expected, especially not with double precision (which is the only option when using KOKKOS). Considering the limitations that you have to deal with when using GPUs and particularly the penalties when using non-KOKKOS features with KOKKOS, you have to manage your expectations. You may find out that using multiple cores on the CPU with MPI may also give you good performance.

This error is likely fixed in a newer release of LAMMPS. If you have the time, I suggest you try out the latest stable and the latest patch release and see what works best for you. We do a lot of automatic testing and - as an unexpected benefit of the pandemic - had more time during the last 15 months to improve the code base and be more thorough with testing and consistency and correctness in the supported features as well as the documentation.

Hi Axel, thanks for your detailed answer. Just to clarify, I want to go by two ways: the first one using eam, airebo, LJ and morse (I forgot to mention this last in my previuous post); and, the second one, with ReaxFF for the same system (or a simplified version of it, depending on the available parameters)

Until now, we have explored the first way with CPU and the results look as we expecting, but if you consider that we are using the hybrid pair_style wrong, I will comment it to my thesis guiders.

So, I tried to summarize all your suggestions in a new installation protocol (please, let my know if I made mistakes):

sudo apt install ocl-icd-opencl-dev
sudo apt-get install openmpi-bin
sudo apt-get install cmake
cd lammps
mkdir build; cd build
cmake ../cmake
cmake -C ../cmake/presets/minimal.cmake .
cmake -D BUILD_MPI=yes .
cmake -D PKG_OPENMP=yes .
cmake -C ../cmake/presets/kokkos-cuda.cmake
cmake -D Kokkos_ARCH_MAXWELL50=no
cmake -D Kokkos_ARCH_PASCAL61=yes
cmake -D Kokkos_ENABLE_OPENMP=yes .
cmake -D PKG_USER-REAXC=yes .
cmake -D PKG_GPU=yes
cmake -D GPU_API=CUDA
cmake -D GPU_ARCH=sm_61 .
cmake -D PKG_MANYBODY=yes .

and tried it with the 29oct20 and the 2Jul21 versions. From the 2Jul2021 I got this message when I executed

$ cmake -C ../cmake/presets/minimal.cmake .

Summary

loading initial cache file …/cmake/presets/minimal.cmake
CMake Error: Error processing file: /mnt/respaldos/executables/lammps-2Jul2021/cmake/presets/minimal.cmake
– Running check for auto-generated files from make-based build system
– Found OpenMP_CXX: -fopenmp
– Found OpenMP: TRUE
– Generating style headers…
– Generating package headers…
– Generating lmpinstalledpkgs.h…
– The following tools and libraries have been found and configured:

  • Git
  • MPI
  • OpenMP
  • JPEG
  • PNG
  • ZLIB

– <<< Build configuration >>>
Operating System: Linux Ubuntu 20.04
Build type: RelWithDebInfo
Install path: /home/g00/.local
Generator: Unix Makefiles using /usr/bin/make
– Enabled packages:
– <<< Compilers and Flags: >>>
– C++ Compiler: /usr/bin/c++
Type: GNU
Version: 9.3.0
C++ Flags: -O2 -g -DNDEBUG
Defines: LAMMPS_SMALLBIG;LAMMPS_MEMALIGN=64;LAMMPS_OMP_COMPAT=4;LAMMPS_JPEG;LAMMPS_PNG;LAMMPS_GZIP;LAMMPS_FFMPEG
– <<< Linker flags: >>>
– Executable name: lmp
– Static library flags:
– <<< MPI flags >>>
– MPI_defines: MPICH_SKIP_MPICXX;OMPI_SKIP_MPICXX;_MPICC_H
– MPI includes: /usr/lib/x86_64-linux-gnu/openmpi/include/openmpi;/usr/lib/x86_64-linux-gnu/openmpi/include
– MPI libraries: /usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi_cxx.so;/usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi.so;
– Configuring incomplete, errors occurred!
See also “/mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeOutput.log”.

(I will put the CMakeOutput.log in another post 'cause the characters limit)

And, from the 29oct20, I executed this command without errors but the kokkos-cuda command returned a failed that I recived also from the 3Mar20 version when I tried to install kokkos for the fist time. , some months ago:

$ cmake -C ../cmake/presets/kokkos-cuda.cmake

Summary

loading initial cache file …/cmake/presets/kokkos-cuda.cmake
– Running check for auto-generated files from make-based build system
– Checking for module ‘fftw3’
– No package ‘fftw3’ found
– KOKKOS: Enabling CUDA LAMBDA function support
– Setting default Kokkos CXX standard to 11
– Setting policy CMP0074 to use _ROOT variables
– The project name is: Kokkos
– Using -std=c++11 for C++11 standard as feature
CMake Error at /mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/cmake/kokkos_test_cxx_std.cmake:120 (MESSAGE):
Invalid compiler for CUDA. The compiler must be nvcc_wrapper or Clang, but
compiler ID was GNU
Call Stack (most recent call first):
/mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/cmake/kokkos_tribits.cmake:201 (INCLUDE)
/mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/CMakeLists.txt:166 (KOKKOS_SETUP_BUILD_ENVIRONMENT)

– Configuring incomplete, errors occurred!
See also “/mnt/respaldos/executables/lammps-29Oct20/buildKokkos/CMakeFiles/CMakeOutput.log”.
You have changed variables that require your cache to be deleted.
Configure will be re-run and you may have to reset some variables.
The following variables have changed:
CMAKE_CXX_COMPILER= /mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper
CMAKE_CXX_COMPILER= /mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper

– Generating done
CMake Generate step failed. Build files cannot be regenerated correctly.

info in /mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper

Summary

#!/bin/bash

This shell script (nvcc_wrapper) wraps both the host compiler and

NVCC, if you are building legacy C or C++ code with CUDA enabled.

The script remedies some differences between the interface of NVCC

and that of the host compiler, in particular for linking.

It also means that a legacy code doesn’t need separate .cu files;

it can just use .cpp files.

Default settings: change those according to your machine. For

example, you may have have two different wrappers with either icpc

or g++ as their back-end compiler. The defaults can be overwritten

by using the usual arguments (e.g., -arch=sm_30 -ccbin icpc).

default_arch=“sm_35”
#default_arch=“sm_50”

The default C++ compiler.

host_compiler=${NVCC_WRAPPER_DEFAULT_COMPILER:-“g++”}

Default to whatever is in the path

nvcc_compiler=nvcc
if [ ! -z $CUDA_ROOT ]; then
nvcc_compiler="$CUDA_ROOT/bin/nvcc"
fi

#host_compiler=“icpc”
#host_compiler="/usr/local/gcc/4.8.3/bin/g++"
#host_compiler="/usr/local/gcc/4.9.1/bin/g++"

Internal variables

C++ files

cpp_files=""

Host compiler arguments

xcompiler_args=""

Cuda (NVCC) only arguments

cuda_args=""

Arguments for both NVCC and Host compiler

shared_args=""

Argument -c

compile_arg=""

Argument -o

output_arg=""

Linker arguments

xlinker_args=""

Object files passable to NVCC

object_files=""

Link objects for the host linker only

object_files_xlinker=""

Shared libraries with version numbers are not handled correctly by NVCC

shared_versioned_libraries_host=""
shared_versioned_libraries=""

Does the User set the architecture

arch_set=0

Does the user overwrite the host compiler

ccbin_set=0

#Error code of compilation
error_code=0

Do a dry run without actually compiling

dry_run=0

Skip NVCC compilation and use host compiler directly

host_only=0
host_only_args=""

Just run version on host compiler

get_host_version=0

Enable workaround for CUDA 6.5 for pragma ident

replace_pragma_ident=0

Mark first host compiler argument

first_xcompiler_arg=1

temp_dir=${TMPDIR:-/tmp}

optimization flag added as a command-line argument

optimization_flag=""

std standard flag added as a command-line argument

std_flag=""

Run nvcc a second time to generate dependencies if needed

depfile_separate=0
depfile_output_arg=""
depfile_target_arg=""

Option to remove duplicate libraries and object files

remove_duplicate_link_files=0

function warn_std_flag() {
echo “nvcc_wrapper - warning you have set multiple standard flags (-std=c++1* or --std=c++1*), only the last is used because nvcc can only accept a single std setting”
}

#echo “Arguments: # @”

while [ $# -gt 0 ]
do
case $1 in
#show the executed command
–show|–nvcc-wrapper-show)
dry_run=1
;;
#run host compilation only
–host-only)
host_only=1
;;
#get the host version only
–host-version)
get_host_version=1
;;
#replace#pragma ident’ with ‘#ident’ this is needed to compile OpenMPI due to a configure script bug and a non standardized behaviour of pragma with macros
–replace-pragma-ident)
replace_pragma_ident=1
;;
#remove duplicate link files
–remove-duplicate-link-files)
remove_duplicate_link_files=1
;;
#handle source files to be compiled as cuda files
.cpp|.cxx|.cc|.C|.c++|.cu)
cpp_files="$cpp_files $1"
;;

Ensure we only have one optimization flag because NVCC doesn’t allow muliple

-O*)
if [ -n “optimization_flag" ]; then echo "nvcc_wrapper - *warning* you have set multiple optimization flags (-O*), only the last is used because nvcc can only accept a single optimization setting." shared_args={shared_args/ $optimization_flag/}
fi
if [ “$1” = “-O” ]; then
optimization_flag=”-O2"
else
optimization_flag=$1
fi
shared_args="$shared_args $optimization_flag"
;;
#Handle shared args (valid for both nvcc and the host compiler)
-D*)
unescape_commas=echo "$1" | sed -e 's/\\\,/,/g'
arg=printf "%q" $unescape_commas
shared_args="$shared_args $arg"
;;
-I*|-L*|-l*|-g|–help|–version|-E|-M|-shared|-w)
shared_args="$shared_args $1"
;;
#Handle compilation argument
-c)
compile_arg="$1"
;;
#Handle output argument
-o)
output_arg="$output_arg $1 $2"
shift
;;

Handle depfile arguments. We map them to a separate call to nvcc.

-MD|-MMD)
depfile_separate=1
host_only_args="$host_only_args $1"
;;
-MF)
depfile_output_arg="-o $2"
host_only_args="$host_only_args $1 $2"
shift
;;
-MT)
depfile_target_arg="$1 $2"
host_only_args="$host_only_args $1 $2"
shift
;;
#Handle known nvcc args
–dryrun|–verbose|–keep|–keep-dir*|-G|–relocatable-device-code*|-lineinfo|-expt-extended-lambda|-expt-relaxed-constexpr|–resource-usage|-Xptxas*|–fmad*|–Wext-lambda-captures-this|-Wext-lambda-captures-this)
cuda_args="$cuda_args $1"
;;
#Handle more known nvcc args
–expt-extended-lambda|–expt-relaxed-constexpr)
cuda_args="$cuda_args $1"
;;
#Handle known nvcc args that have an argument
-rdc|-maxrregcount|–default-stream|-Xnvlink|–fmad|-cudart|–cudart)
cuda_args="$cuda_args $1 $2"
shift
;;
-rdc=|-maxrregcount|–maxrregcount*)
cuda_args="$cuda_args $1"
;;
#Handle unsupported standard flags
–std=c++1y|-std=c++1y|–std=gnu++1y|-std=gnu++1y|–std=c++1z|-std=c++1z|–std=gnu++1z|-std=gnu++1z|–std=c++2a|-std=c++2a)
fallback_std_flag="-std=c++14"
# this is hopefully just occurring in a downstream project during CMake feature tests
# we really have no choice here but to accept the flag and change to an accepted C++ standard
echo “nvcc_wrapper does not accept standard flags $1 since partial standard flags and standards after C++17 are not supported. nvcc_wrapper will use $fallback_std_flag instead. It is undefined behavior to use this flag. This should only be occurring during CMake configuration.”
if [ -n “std_flag" ]; then warn_std_flag shared_args={shared_args/ $std_flag/}
fi
std_flag=$fallback_std_flag
shared_args=”$shared_args std_flag" ;; -std=gnu*) corrected_std_flag={1/gnu/c}
echo “nvcc_wrapper has been given GNU extension standard flag $1 - reverting flag to $corrected_std_flag”
if [ -n “std_flag" ]; then warn_std_flag shared_args={shared_args/ $std_flag/}
fi
std_flag=$corrected_std_flag
shared_args=”$shared_args $std_flag"
;;
–std=c++17|-std=c++17)
if [ -n “std_flag" ]; then warn_std_flag shared_args={shared_args/ std_flag/} fi # NVCC only has C++17 from version 11 on cuda_main_version=([[ ({nvcc_compiler} --version) =~ V([0-9]+) ]] && echo {BASH_REMATCH[1]}) if [ {cuda_main_version} -lt 11 ]; then
fallback_std_flag=”-std=c++14"
# this is hopefully just occurring in a downstream project during CMake feature tests
# we really have no choice here but to accept the flag and change to an accepted C++ standard
echo “nvcc_wrapper does not accept standard flags $1 since partial standard flags and standards after C++14 are not supported. nvcc_wrapper will use $fallback_std_flag instead. It is undefined behavior to use this flag. This should only be occurring during CMake configuration.”
std_flag=$fallback_std_flag
else
std_flag=$1
fi
shared_args="$shared_args $std_flag"
;;
–std=c++11|-std=c++11|–std=c++14|-std=c++14)
if [ -n “std_flag" ]; then warn_std_flag shared_args={shared_args/ $std_flag/}
fi
std_flag=$1
shared_args=”$shared_args $std_flag"
;;

#convert PGI standard flags to something nvcc can handle
–c++11|–c++14|–c++17)
if [ -n “std_flag" ]; then warn_std_flag shared_args={shared_args/ std_flag/} fi std_flag="-std={1#–}”
shared_args="$shared_args $std_flag"
;;

#ignore PGI forcing ISO C+±conforming code
-A)
;;

#strip of -std=c++98 due to nvcc warnings and Tribits will place both -std=c++11 and -std=c++98
-std=c++98|–std=c++98)
;;
#strip of pedantic because it produces endless warnings about #LINE added by the preprocessor
-pedantic|-Wpedantic|-ansi)
;;
#strip of -Woverloaded-virtual to avoid “cc1: warning: command line option ‘-Woverloaded-virtual’ is valid for C++/ObjC++ but not for C”
-Woverloaded-virtual)
;;
#strip -Xcompiler because we add it
-Xcompiler)
if [[ $2 != “-o” ]]; then
if [ $first_xcompiler_arg -eq 1 ]; then
xcompiler_args="$2"
first_xcompiler_arg=0
else
xcompiler_args="$xcompiler_args,$2"
fi
shift
fi
# else this we have -Xcompiler -o , in this case just drop -Xcompiler and process
# the -o flag with the filename (done above)
;;
#strip of “-x cu” because we add that
-x)
if [[ $2 != “cu” ]]; then
if [ $first_xcompiler_arg -eq 1 ]; then
xcompiler_args="-x,$2"
first_xcompiler_arg=0
else
xcompiler_args="$xcompiler_args,-x,$2"
fi
fi
shift
;;
#Handle -+ (same as -x c++, specifically used for xl compilers, but mutually exclusive with -x. So replace it with -x c++)
-+)
if [ $first_xcompiler_arg -eq 1 ]; then
xcompiler_args="-x,c++"
first_xcompiler_arg=0
else
xcompiler_args="$xcompiler_args,-x,c++"
fi
;;
#Handle -ccbin (if its not set we can set it to a default value)
-ccbin)
cuda_args="$cuda_args $1 $2"
ccbin_set=1
host_compiler=$2
shift
;;

#Handle -arch argument (if its not set use a default) this is the version with = sign
-arch*|-gencode*)
cuda_args="$cuda_args $1"
arch_set=1
;;
#Handle -code argument (if its not set use a default) this is the version with = sign
-code*)
cuda_args="$cuda_args $1"
;;
#Handle -arch argument (if its not set use a default) this is the version without = sign
-arch|-gencode)
cuda_args="$cuda_args $1 $2"
arch_set=1
shift
;;
#Handle -code argument (if its not set use a default) this is the version without = sign
-code)
cuda_args="$cuda_args $1 $2"
shift
;;
#Handle -Xcudafe argument
-Xcudafe)
cuda_args="$cuda_args -Xcudafe $2"
shift
;;
#Handle -Xlinker argument
-Xlinker)
xlinker_args="$xlinker_args -Xlinker $2"
shift
;;
#Handle args that should be sent to the linker
-Wl,)
xlinker_args="xlinker_args -Xlinker {1:4:${#1}}"
host_linker_args="host_linker_args {1:4:${#1}}"
;;
#Handle object files: -x cu applies to all input files, so give them to linker, except if only linking
.a|.so|
.o|.obj)
object_files="$object_files $1"
object_files_xlinker="$object_files_xlinker -Xlinker $1"
;;
#Handle object files which always need to use “-Xlinker”: -x cu applies to all input files, so give them to linker, except if only linking
@
|*.dylib)
object_files="$object_files -Xlinker $1"
object_files_xlinker="$object_files_xlinker -Xlinker $1"
;;
#Handle shared libraries with .so. names which nvcc can’t do.
.so.)
shared_versioned_libraries_host="$shared_versioned_libraries_host $1"
shared_versioned_libraries="$shared_versioned_libraries -Xlinker $1"
;;
#All other args are sent to the host compiler
*)
if [ $first_xcompiler_arg -eq 1 ]; then
xcompiler_args=$1
first_xcompiler_arg=0
else
xcompiler_args="$xcompiler_args,$1"
fi
;;
esac

shift
done

Only print host compiler version

if [ $get_host_version -eq 1 ]; then
$host_compiler --version
exit
fi

#Remove duplicate object files
if [ $remove_duplicate_link_files -eq 1 ]; then
for obj in $object_files
do
object_files_reverse="$obj $object_files_reverse"
done

object_files_reverse_clean=""
for obj in $object_files_reverse
do
exists=false
for obj2 in $object_files_reverse_clean
do
if [ “$obj” == “$obj2” ]
then
exists=true
echo “Exists: $obj”
fi
done
if [ “$exists” == “false” ]
then
object_files_reverse_clean="$object_files_reverse_clean $obj"
fi
done

object_files=""
for obj in $object_files_reverse_clean
do
object_files="$obj $object_files"
done
fi

#Add default host compiler if necessary
if [ $ccbin_set -ne 1 ]; then
cuda_args="$cuda_args -ccbin $host_compiler"
fi

#Add architecture command
if [ $arch_set -ne 1 ]; then
cuda_args="$cuda_args -arch=$default_arch"
fi

#Compose compilation command
nvcc_command="$nvcc_compiler $cuda_args $shared_args $xlinker_args $shared_versioned_libraries"
if [ $first_xcompiler_arg -eq 0 ]; then
nvcc_command="$nvcc_command -Xcompiler $xcompiler_args"
fi

#Replace all commas in xcompiler_args with a space for the host only command
xcompiler_args=${xcompiler_args//,/" "}

#Compose host only command
host_command="$host_compiler $shared_args $host_only_args $compile_arg $output_arg $xcompiler_args $host_linker_args $shared_versioned_libraries_host"

#nvcc does not accept ‘#pragma ident SOME_MACRO_STRING’ but it does accept ‘#ident SOME_MACRO_STRING’
if [ $replace_pragma_ident -eq 1 ]; then
cpp_files2=""
for file in cpp_files do var=`grep pragma {file} | grep ident | grep “#”`
if [ “${#var}” -gt 0 ]
then
sed ‘s/#[\ \t]*pragma[\ \t]*ident/#ident/g’ $file > $temp_dir/nvcc_wrapper_tmp_$file
cpp_files2="$cpp_files2 $temp_dir/nvcc_wrapper_tmp_$file"
else
cpp_files2="$cpp_files2 $file"
fi
done
cpp_files=$cpp_files2
#echo $cpp_files
fi

if [ “$cpp_files” ]; then
nvcc_command="$nvcc_command $object_files_xlinker -x cu $cpp_files"
else
nvcc_command="$nvcc_command $object_files"
fi

if [ “$cpp_files” ]; then
host_command="$host_command $object_files $cpp_files"
else
host_command="$host_command $object_files"
fi

if [ $depfile_separate -eq 1 ]; then

run nvcc a second time to generate dependencies (without compiling)

nvcc_depfile_command="$nvcc_command -M $depfile_target_arg $depfile_output_arg"
else
nvcc_depfile_command=""
fi

nvcc_command="$nvcc_command $compile_arg $output_arg"

#Print command for dryrun
if [ $dry_run -eq 1 ]; then
if [ $host_only -eq 1 ]; then
echo $host_command
elif [ -n “$nvcc_depfile_command” ]; then
echo $nvcc_command “&&” $nvcc_depfile_command
else
echo $nvcc_command
fi
exit 0
fi

#Run compilation command
if [ $host_only -eq 1 ]; then
if [ “$NVCC_WRAPPER_SHOW_COMMANDS_BEING_RUN” == “1” ] ; then
echo “$host_command”
fi
$host_command
elif [ -n “$nvcc_depfile_command” ]; then
if [ “$NVCC_WRAPPER_SHOW_COMMANDS_BEING_RUN” == “1” ] ; then
echo “$nvcc_command && $nvcc_depfile_command”
fi
$nvcc_command && $nvcc_depfile_command
else
if [ “$NVCC_WRAPPER_SHOW_COMMANDS_BEING_RUN” == “1” ] ; then
echo “$nvcc_command”
fi
nvcc_command fi error_code=?

#Report error code
exit $error_code

The file buildKokkos/CMakeFiles/CMakeOutput.log was not created for this second case.
What could be?

/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeOutput.log

Summary

The system is: Linux - 5.4.0-77-generic - x86_64
Compiling the CXX compiler identification source file “CMakeCXXCompilerId.cpp” succeeded.
Compiler: /usr/bin/c++
Build flags:
Id flags:

The output was:
0

Compilation of the CXX compiler identification source “CMakeCXXCompilerId.cpp” produced “a.out”

The CXX compiler identification is GNU, found in “/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/3.16.3/CompilerIdCXX/a.out”

Determining if the CXX compiler works passed with the following output:
Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/make cmTC_ea1d1/fast && /usr/bin/make -f CMakeFiles/cmTC_ea1d1.dir/build.make CMakeFiles/cmTC_ea1d1.dir/build
make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’
Building CXX object CMakeFiles/cmTC_ea1d1.dir/testCXXCompiler.cxx.o
/usr/bin/c++ -o CMakeFiles/cmTC_ea1d1.dir/testCXXCompiler.cxx.o -c /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp/testCXXCompiler.cxx
Linking CXX executable cmTC_ea1d1
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_ea1d1.dir/link.txt --verbose=1
/usr/bin/c++ CMakeFiles/cmTC_ea1d1.dir/testCXXCompiler.cxx.o -o cmTC_ea1d1
make[1]: Leaving directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’

Detecting CXX compiler ABI info compiled with the following output:
Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/make cmTC_348f1/fast && /usr/bin/make -f CMakeFiles/cmTC_348f1.dir/build.make CMakeFiles/cmTC_348f1.dir/build
make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’
Building CXX object CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o
/usr/bin/c++ -v -o CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -c /usr/share/cmake-3.16/Modules/CMakeCXXCompilerABI.cpp
Using built-in specs.
COLLECT_GCC=/usr/bin/c++
OFFLOAD_TARGET_NAMES=nvptx-none:hsa
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr,hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)
COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’
/usr/lib/gcc/x86_64-linux-gnu/9/cc1plus -quiet -v -imultiarch x86_64-linux-gnu -D_GNU_SOURCE /usr/share/cmake-3.16/Modules/CMakeCXXCompilerABI.cpp -quiet -dumpbase CMakeCXXCompilerABI.cpp -mtune=generic -march=x86-64 -auxbase-strip CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -version -fasynchronous-unwind-tables -fstack-protector-strong -Wformat -Wformat-security -fstack-clash-protection -fcf-protection -o /tmp/ccqqKDzX.s
GNU C++14 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)
compiled by GNU C version 9.3.0, GMP version 6.2.0, MPFR version 4.0.2, MPC version 1.1.0, isl version isl-0.22.1-GMP

GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
ignoring duplicate directory “/usr/include/x86_64-linux-gnu/c++/9”
ignoring nonexistent directory “/usr/local/include/x86_64-linux-gnu”
ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/include-fixed”
ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/x86_64-linux-gnu/include”
#include “…” search starts here:
#include <…> search starts here:
/usr/include/c++/9
/usr/include/x86_64-linux-gnu/c++/9
/usr/include/c++/9/backward
/usr/lib/gcc/x86_64-linux-gnu/9/include
/usr/local/include
/usr/include/x86_64-linux-gnu
/usr/include
End of search list.
GNU C++14 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)
compiled by GNU C version 9.3.0, GMP version 6.2.0, MPFR version 4.0.2, MPC version 1.1.0, isl version isl-0.22.1-GMP

GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: 466f818abe2f30ba03783f22bd12d815
COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’
as -v --64 -o CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o /tmp/ccqqKDzX.s
GNU assembler version 2.34 (x86_64-linux-gnu) using BFD version (GNU Binutils for Ubuntu) 2.34
COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/
LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/
COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’
Linking CXX executable cmTC_348f1
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_348f1.dir/link.txt --verbose=1
/usr/bin/c++ -v CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -o cmTC_348f1
Using built-in specs.
COLLECT_GCC=/usr/bin/c++
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none:hsa
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr,hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)
COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/
LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/
COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘cmTC_348f1’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’
/usr/lib/gcc/x86_64-linux-gnu/9/collect2 -plugin /usr/lib/gcc/x86_64-linux-gnu/9/liblto_plugin.so -plugin-opt=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper -plugin-opt=-fresolution=/tmp/ccIxmUom.res -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lc -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc --build-id --eh-frame-hdr -m elf_x86_64 --hash-style=gnu --as-needed -dynamic-linker /lib64/ld-linux-x86-64.so.2 -pie -z now -z relro -o cmTC_348f1 /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/Scrt1.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crti.o /usr/lib/gcc/x86_64-linux-gnu/9/crtbeginS.o -L/usr/lib/gcc/x86_64-linux-gnu/9 -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib -L/lib/x86_64-linux-gnu -L/lib/…/lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/…/lib -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/… CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -lstdc++ -lm -lgcc_s -lgcc -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-linux-gnu/9/crtendS.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crtn.o
COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘cmTC_348f1’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’
make[1]: Leaving directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’

Parsed CXX implicit include dir info from above output: rv=done
found start of include info
found start of implicit include info
add: [/usr/include/c++/9]
add: [/usr/include/x86_64-linux-gnu/c++/9]
add: [/usr/include/c++/9/backward]
add: [/usr/lib/gcc/x86_64-linux-gnu/9/include]
add: [/usr/local/include]
add: [/usr/include/x86_64-linux-gnu]
add: [/usr/include]
end of search list found
collapse include dir [/usr/include/c++/9] ==> [/usr/include/c++/9]
collapse include dir [/usr/include/x86_64-linux-gnu/c++/9] ==> [/usr/include/x86_64-linux-gnu/c++/9]
collapse include dir [/usr/include/c++/9/backward] ==> [/usr/include/c++/9/backward]
collapse include dir [/usr/lib/gcc/x86_64-linux-gnu/9/include] ==> [/usr/lib/gcc/x86_64-linux-gnu/9/include]
collapse include dir [/usr/local/include] ==> [/usr/local/include]
collapse include dir [/usr/include/x86_64-linux-gnu] ==> [/usr/include/x86_64-linux-gnu]
collapse include dir [/usr/include] ==> [/usr/include]
implicit include dirs: [/usr/include/c++/9;/usr/include/x86_64-linux-gnu/c++/9;/usr/include/c++/9/backward;/usr/lib/gcc/x86_64-linux-gnu/9/include;/usr/local/include;/usr/include/x86_64-linux-gnu;/usr/include]

Parsed CXX implicit link information from above output:
link line regex: [^( |.[/])(ld|CMAKE_LINK_STARTFILE-NOTFOUND|([^/]±)?ld|collect2)[^/]*( |$)]
ignore line: [Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp]
ignore line: []
ignore line: [Run Build Command(s):/usr/bin/make cmTC_348f1/fast && /usr/bin/make -f CMakeFiles/cmTC_348f1.dir/build.make CMakeFiles/cmTC_348f1.dir/build]
ignore line: [make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’]
ignore line: [Building CXX object CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o]
ignore line: [/usr/bin/c++ -v -o CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -c /usr/share/cmake-3.16/Modules/CMakeCXXCompilerABI.cpp]
ignore line: [Using built-in specs.]
ignore line: [COLLECT_GCC=/usr/bin/c++]
ignore line: [OFFLOAD_TARGET_NAMES=nvptx-none:hsa]
ignore line: [OFFLOAD_TARGET_DEFAULT=1]
ignore line: [Target: x86_64-linux-gnu]
ignore line: [Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c ada c++ go brig d fortran objc obj-c++ gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32 m64 mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu]
ignore line: [Thread model: posix]
ignore line: [gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04) ]
ignore line: [COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’]
ignore line: [ /usr/lib/gcc/x86_64-linux-gnu/9/cc1plus -quiet -v -imultiarch x86_64-linux-gnu -D_GNU_SOURCE /usr/share/cmake-3.16/Modules/CMakeCXXCompilerABI.cpp -quiet -dumpbase CMakeCXXCompilerABI.cpp -mtune=generic -march=x86-64 -auxbase-strip CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -version -fasynchronous-unwind-tables -fstack-protector-strong -Wformat -Wformat-security -fstack-clash-protection -fcf-protection -o /tmp/ccqqKDzX.s]
ignore line: [GNU C++14 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)]
ignore line: [ compiled by GNU C version 9.3.0 GMP version 6.2.0 MPFR version 4.0.2 MPC version 1.1.0 isl version isl-0.22.1-GMP]
ignore line: []
ignore line: [GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072]
ignore line: [ignoring duplicate directory “/usr/include/x86_64-linux-gnu/c++/9”]
ignore line: [ignoring nonexistent directory “/usr/local/include/x86_64-linux-gnu”]
ignore line: [ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/include-fixed”]
ignore line: [ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/x86_64-linux-gnu/include”]
ignore line: [#include “…” search starts here:]
ignore line: [#include <…> search starts here:]
ignore line: [ /usr/include/c++/9]
ignore line: [ /usr/include/x86_64-linux-gnu/c++/9]
ignore line: [ /usr/include/c++/9/backward]
ignore line: [ /usr/lib/gcc/x86_64-linux-gnu/9/include]
ignore line: [ /usr/local/include]
ignore line: [ /usr/include/x86_64-linux-gnu]
ignore line: [ /usr/include]
ignore line: [End of search list.]
ignore line: [GNU C++14 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)]
ignore line: [ compiled by GNU C version 9.3.0 GMP version 6.2.0 MPFR version 4.0.2 MPC version 1.1.0 isl version isl-0.22.1-GMP]
ignore line: []
ignore line: [GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072]
ignore line: [Compiler executable checksum: 466f818abe2f30ba03783f22bd12d815]
ignore line: [COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’]
ignore line: [ as -v --64 -o CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o /tmp/ccqqKDzX.s]
ignore line: [GNU assembler version 2.34 (x86_64-linux-gnu) using BFD version (GNU Binutils for Ubuntu) 2.34]
ignore line: [COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/]
ignore line: [LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/]
ignore line: [COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’]
ignore line: [Linking CXX executable cmTC_348f1]
ignore line: [/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_348f1.dir/link.txt --verbose=1]
ignore line: [/usr/bin/c++ -v CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -o cmTC_348f1 ]
ignore line: [Using built-in specs.]
ignore line: [COLLECT_GCC=/usr/bin/c++]
ignore line: [COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper]
ignore line: [OFFLOAD_TARGET_NAMES=nvptx-none:hsa]
ignore line: [OFFLOAD_TARGET_DEFAULT=1]
ignore line: [Target: x86_64-linux-gnu]
ignore line: [Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c ada c++ go brig d fortran objc obj-c++ gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32 m64 mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu]
ignore line: [Thread model: posix]
ignore line: [gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04) ]
ignore line: [COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/]
ignore line: [LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/]
ignore line: [COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘cmTC_348f1’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’]
link line: [ /usr/lib/gcc/x86_64-linux-gnu/9/collect2 -plugin /usr/lib/gcc/x86_64-linux-gnu/9/liblto_plugin.so -plugin-opt=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper -plugin-opt=-fresolution=/tmp/ccIxmUom.res -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lc -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc --build-id --eh-frame-hdr -m elf_x86_64 --hash-style=gnu --as-needed -dynamic-linker /lib64/ld-linux-x86-64.so.2 -pie -z now -z relro -o cmTC_348f1 /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/Scrt1.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crti.o /usr/lib/gcc/x86_64-linux-gnu/9/crtbeginS.o -L/usr/lib/gcc/x86_64-linux-gnu/9 -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib -L/lib/x86_64-linux-gnu -L/lib/…/lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/…/lib -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/… CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o -lstdc++ -lm -lgcc_s -lgcc -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-linux-gnu/9/crtendS.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crtn.o]
arg [/usr/lib/gcc/x86_64-linux-gnu/9/collect2] ==> ignore
arg [-plugin] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/liblto_plugin.so] ==> ignore
arg [-plugin-opt=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper] ==> ignore
arg [-plugin-opt=-fresolution=/tmp/ccIxmUom.res] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc_s] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc] ==> ignore
arg [-plugin-opt=-pass-through=-lc] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc_s] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc] ==> ignore
arg [–build-id] ==> ignore
arg [–eh-frame-hdr] ==> ignore
arg [-m] ==> ignore
arg [elf_x86_64] ==> ignore
arg [–hash-style=gnu] ==> ignore
arg [–as-needed] ==> ignore
arg [-dynamic-linker] ==> ignore
arg [/lib64/ld-linux-x86-64.so.2] ==> ignore
arg [-pie] ==> ignore
arg [-znow] ==> ignore
arg [-zrelro] ==> ignore
arg [-o] ==> ignore
arg [cmTC_348f1] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/Scrt1.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crti.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/crtbeginS.o] ==> ignore
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9]
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu]
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib]
arg [-L/lib/x86_64-linux-gnu] ==> dir [/lib/x86_64-linux-gnu]
arg [-L/lib/…/lib] ==> dir [/lib/…/lib]
arg [-L/usr/lib/x86_64-linux-gnu] ==> dir [/usr/lib/x86_64-linux-gnu]
arg [-L/usr/lib/…/lib] ==> dir [/usr/lib/…/lib]
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…]
arg [CMakeFiles/cmTC_348f1.dir/CMakeCXXCompilerABI.cpp.o] ==> ignore
arg [-lstdc++] ==> lib [stdc++]
arg [-lm] ==> lib [m]
arg [-lgcc_s] ==> lib [gcc_s]
arg [-lgcc] ==> lib [gcc]
arg [-lc] ==> lib [c]
arg [-lgcc_s] ==> lib [gcc_s]
arg [-lgcc] ==> lib [gcc]
arg [/usr/lib/gcc/x86_64-linux-gnu/9/crtendS.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crtn.o] ==> ignore
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9] ==> [/usr/lib/gcc/x86_64-linux-gnu/9]
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu] ==> [/usr/lib/x86_64-linux-gnu]
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib] ==> [/usr/lib]
collapse library dir [/lib/x86_64-linux-gnu] ==> [/lib/x86_64-linux-gnu]
collapse library dir [/lib/…/lib] ==> [/lib]
collapse library dir [/usr/lib/x86_64-linux-gnu] ==> [/usr/lib/x86_64-linux-gnu]
collapse library dir [/usr/lib/…/lib] ==> [/usr/lib]
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…] ==> [/usr/lib]
implicit libs: [stdc++;m;gcc_s;gcc;c;gcc_s;gcc]
implicit dirs: [/usr/lib/gcc/x86_64-linux-gnu/9;/usr/lib/x86_64-linux-gnu;/usr/lib;/lib/x86_64-linux-gnu;/lib]
implicit fwks: []

continuation

Summary

Detecting CXX OpenMP compiler ABI info compiled with the following output:
Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/make cmTC_30c90/fast && /usr/bin/make -f CMakeFiles/cmTC_30c90.dir/build.make CMakeFiles/cmTC_30c90.dir/build
make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’
Building CXX object CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o
/usr/bin/c++ -fopenmp -v -std=c++11 -o CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -c /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/FindOpenMP/OpenMPTryFlag.cpp
Using built-in specs.
COLLECT_GCC=/usr/bin/c++
OFFLOAD_TARGET_NAMES=nvptx-none:hsa
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,gm2 --prefix=/usr --with-gcc-major-version-only -Detecting CXX OpenMP compiler ABI info compiled with the following output:
Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/make cmTC_30c90/fast && /usr/bin/make -f CMakeFiles/cmTC_30c90.dir/build.make CMakeFiles/cmTC_30c90.dir/build
make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’
Building CXX object CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o
/usr/bin/c++ -fopenmp -v -std=c++11 -o CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -c /mnt/respaldos/executables/lammps-ject --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr,hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)
COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-std=c++11’ ‘-o’ ‘CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’
/usr/lib/gcc/x86_64-linux-gnu/9/cc1plus -quiet -v -imultiarch x86_64-linux-gnu -D_GNU_SOURCE -D_REENTRANT /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/FindOpenMP/OpenMPTryFlag.cpp -quiet -dumpbase OpenMPTryFlag.cpp -mtune=generic -march=x86-64 -auxbase-strip CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -std=c++11 -version -fopenmp -fasynchronous-unwind-tables -fstack-protector-strong -Wformat -Wformat-security -fstack-clash-protection -fcf-protection -o /tmp/cciH11EK.s
GNU C++11 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)
compiled by GNU C version 9.3.0, GMP version 6.2.0, MPFR version 4.0.2, MPC version 1.1.0, isl version isl-0.22.1-GMP

GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
ignoring duplicate directory “/usr/include/x86_64-linux-gnu/c++/9”
ignoring nonexistent directory “/usr/local/include/x86_64-linux-gnu”
ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/include-fixed”
ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/x86_64-linux-gnu/include”
#include “…” search starts here:
#include <…> search starts here:
/usr/include/c++/9
/usr/include/x86_64-linux-gnu/c++/9
/usr/include/c++/9/backward
/usr/lib/gcc/x86_64-linux-gnu/9/include
/usr/local/include
/usr/include/x86_64-linux-gnu
/usr/include
End of search list.
GNU C++11 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)
compiled by GNU C version 9.3.0, GMP version 6.2.0, MPFR version 4.0.2, MPC version 1.1.0, isl version isl-0.22.1-GMP

GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: 466f818abe2f30ba03783f22bd12d815
COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-std=c++11’ ‘-o’ ‘CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’
as -v --64 -o CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o /tmp/cciH11EK.s
GNU assembler version 2.34 (x86_64-linux-gnu) using BFD version (GNU Binutils for Ubuntu) 2.34
COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/
LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/
COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-std=c++11’ ‘-o’ ‘CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’
Linking CXX executable cmTC_30c90
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_30c90.dir/link.txt --verbose=1
/usr/bin/c++ -fopenmp -v CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -o cmTC_30c90 -v
Using built-in specs.
COLLECT_GCC=/usr/bin/c++
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none:hsa
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr,hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)
COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/
LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/
Reading specs from /usr/lib/gcc/x86_64-linux-gnu/9/libgomp.spec
COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-o’ ‘cmTC_30c90’ ‘-v’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’
/usr/lib/gcc/x86_64-linux-gnu/9/collect2 -plugin /usr/lib/gcc/x86_64-linux-gnu/9/liblto_plugin.so -plugin-opt=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper -plugin-opt=-fresolution=/tmp/ccrdChKg.res -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lpthread -plugin-opt=-pass-through=-lc -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc --build-id --eh-frame-hdr -m elf_x86_64 --hash-style=gnu --as-needed -dynamic-linker /lib64/ld-linux-x86-64.so.2 -pie -z now -z relro -o cmTC_30c90 /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/Scrt1.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crti.o /usr/lib/gcc/x86_64-linux-gnu/9/crtbeginS.o /usr/lib/gcc/x86_64-linux-gnu/9/crtoffloadbegin.o -L/usr/lib/gcc/x86_64-linux-gnu/9 -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib -L/lib/x86_64-linux-gnu -L/lib/…/lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/…/lib -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/… CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -lstdc++ -lm -lgomp -lgcc_s -lgcc -lpthread -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-linux-gnu/9/crtendS.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crtn.o /usr/lib/gcc/x86_64-linux-gnu/9/crtoffloadend.o
COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-o’ ‘cmTC_30c90’ ‘-v’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’
make[1]: Leaving directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’

Parsed CXX OpenMP implicit link information from above output:
link line regex: [^( |.[/])(ld|CMAKE_LINK_STARTFILE-NOTFOUND|([^/]±)?ld|collect2)[^/]*( |$)]
ignore line: [Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp]
ignore line: []
ignore line: [Run Build Command(s):/usr/bin/make cmTC_30c90/fast && /usr/bin/make -f CMakeFiles/cmTC_30c90.dir/build.make CMakeFiles/cmTC_30c90.dir/build]
ignore line: [make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’]
ignore line: [Building CXX object CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o]
ignore line: [/usr/bin/c++ -fopenmp -v -std=c++11 -o CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -c /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/FindOpenMP/OpenMPTryFlag.cpp]
ignore line: [Using built-in specs.]
ignore line: [COLLECT_GCC=/usr/bin/c++]
ignore line: [OFFLOAD_TARGET_NAMES=nvptx-none:hsa]
ignore line: [OFFLOAD_TARGET_DEFAULT=1]
ignore line: [Target: x86_64-linux-gnu]
ignore line: [Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c ada c++ go brig d fortran objc obj-c++ gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32 m64 mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu]
ignore line: [Thread model: posix]
ignore line: [gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04) ]
ignore line: [COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-std=c++11’ ‘-o’ ‘CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’]
ignore line: [ /usr/lib/gcc/x86_64-linux-gnu/9/cc1plus -quiet -v -imultiarch x86_64-linux-gnu -D_GNU_SOURCE -D_REENTRANT /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/FindOpenMP/OpenMPTryFlag.cpp -quiet -dumpbase OpenMPTryFlag.cpp -mtune=generic -march=x86-64 -auxbase-strip CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -std=c++11 -version -fopenmp -fasynchronous-unwind-tables -fstack-protector-strong -Wformat -Wformat-security -fstack-clash-protection -fcf-protection -o /tmp/cciH11EK.s]
ignore line: [GNU C++11 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)]
ignore line: [ compiled by GNU C version 9.3.0 GMP version 6.2.0 MPFR version 4.0.2 MPC version 1.1.0 isl version isl-0.22.1-GMP]
ignore line: []
ignore line: [GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072]
ignore line: [ignoring duplicate directory “/usr/include/x86_64-linux-gnu/c++/9”]
ignore line: [ignoring nonexistent directory “/usr/local/include/x86_64-linux-gnu”]
ignore line: [ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/include-fixed”]
ignore line: [ignoring nonexistent directory “/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/x86_64-linux-gnu/include”]
ignore line: [#include “…” search starts here:]
ignore line: [#include <…> search starts here:]
ignore line: [ /usr/include/c++/9]
ignore line: [ /usr/include/x86_64-linux-gnu/c++/9]
ignore line: [ /usr/include/c++/9/backward]
ignore line: [ /usr/lib/gcc/x86_64-linux-gnu/9/include]
ignore line: [ /usr/local/include]
ignore line: [ /usr/include/x86_64-linux-gnu]
ignore line: [ /usr/include]
ignore line: [End of search list.]
ignore line: [GNU C++11 (Ubuntu 9.3.0-17ubuntu1~20.04) version 9.3.0 (x86_64-linux-gnu)]
ignore line: [ compiled by GNU C version 9.3.0 GMP version 6.2.0 MPFR version 4.0.2 MPC version 1.1.0 isl version isl-0.22.1-GMP]
ignore line: []
ignore line: [GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072]
ignore line: [Compiler executable checksum: 466f818abe2f30ba03783f22bd12d815]
ignore line: [COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-std=c++11’ ‘-o’ ‘CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’]
ignore line: [ as -v --64 -o CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o /tmp/cciH11EK.s]
ignore line: [GNU assembler version 2.34 (x86_64-linux-gnu) using BFD version (GNU Binutils for Ubuntu) 2.34]
ignore line: [COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/]
ignore line: [LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/]
ignore line: [COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-std=c++11’ ‘-o’ ‘CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o’ ‘-c’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’]
ignore line: [Linking CXX executable cmTC_30c90]
ignore line: [/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_30c90.dir/link.txt --verbose=1]
ignore line: [/usr/bin/c++ -fopenmp -v CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -o cmTC_30c90 -v ]
ignore line: [Using built-in specs.]
ignore line: [COLLECT_GCC=/usr/bin/c++]
ignore line: [COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper]
ignore line: [OFFLOAD_TARGET_NAMES=nvptx-none:hsa]
ignore line: [OFFLOAD_TARGET_DEFAULT=1]
ignore line: [Target: x86_64-linux-gnu]
ignore line: [Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c ada c++ go brig d fortran objc obj-c++ gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32 m64 mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu]
ignore line: [Thread model: posix]
ignore line: [gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04) ]
ignore line: [COMPILER_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/]
ignore line: [LIBRARY_PATH=/usr/lib/gcc/x86_64-linux-gnu/9/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib/:/lib/x86_64-linux-gnu/:/lib/…/lib/:/usr/lib/x86_64-linux-gnu/:/usr/lib/…/lib/:/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/:/lib/:/usr/lib/]
ignore line: [Reading specs from /usr/lib/gcc/x86_64-linux-gnu/9/libgomp.spec]
ignore line: [COLLECT_GCC_OPTIONS=’-fopenmp’ ‘-v’ ‘-o’ ‘cmTC_30c90’ ‘-v’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’ ‘-pthread’]
link line: [ /usr/lib/gcc/x86_64-linux-gnu/9/collect2 -plugin /usr/lib/gcc/x86_64-linux-gnu/9/liblto_plugin.so -plugin-opt=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper -plugin-opt=-fresolution=/tmp/ccrdChKg.res -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lpthread -plugin-opt=-pass-through=-lc -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc --build-id --eh-frame-hdr -m elf_x86_64 --hash-style=gnu --as-needed -dynamic-linker /lib64/ld-linux-x86-64.so.2 -pie -z now -z relro -o cmTC_30c90 /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/Scrt1.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crti.o /usr/lib/gcc/x86_64-linux-gnu/9/crtbeginS.o /usr/lib/gcc/x86_64-linux-gnu/9/crtoffloadbegin.o -L/usr/lib/gcc/x86_64-linux-gnu/9 -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib -L/lib/x86_64-linux-gnu -L/lib/…/lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/…/lib -L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/… CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o -lstdc++ -lm -lgomp -lgcc_s -lgcc -lpthread -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-linux-gnu/9/crtendS.o /usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crtn.o /usr/lib/gcc/x86_64-linux-gnu/9/crtoffloadend.o]
arg [/usr/lib/gcc/x86_64-linux-gnu/9/collect2] ==> ignore
arg [-plugin] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/liblto_plugin.so] ==> ignore
arg [-plugin-opt=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper] ==> ignore
arg [-plugin-opt=-fresolution=/tmp/ccrdChKg.res] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc_s] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc] ==> ignore
arg [-plugin-opt=-pass-through=-lpthread] ==> ignore
arg [-plugin-opt=-pass-through=-lc] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc_s] ==> ignore
arg [-plugin-opt=-pass-through=-lgcc] ==> ignore
arg [–build-id] ==> ignore
arg [–eh-frame-hdr] ==> ignore
arg [-m] ==> ignore
arg [elf_x86_64] ==> ignore
arg [–hash-style=gnu] ==> ignore
arg [–as-needed] ==> ignore
arg [-dynamic-linker] ==> ignore
arg [/lib64/ld-linux-x86-64.so.2] ==> ignore
arg [-pie] ==> ignore
arg [-znow] ==> ignore
arg [-zrelro] ==> ignore
arg [-o] ==> ignore
arg [cmTC_30c90] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/Scrt1.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crti.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/crtbeginS.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/crtoffloadbegin.o] ==> ignore
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9]
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu]
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib]
arg [-L/lib/x86_64-linux-gnu] ==> dir [/lib/x86_64-linux-gnu]
arg [-L/lib/…/lib] ==> dir [/lib/…/lib]
arg [-L/usr/lib/x86_64-linux-gnu] ==> dir [/usr/lib/x86_64-linux-gnu]
arg [-L/usr/lib/…/lib] ==> dir [/usr/lib/…/lib]
arg [-L/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…] ==> dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…]
arg [CMakeFiles/cmTC_30c90.dir/OpenMPTryFlag.cpp.o] ==> ignore
arg [-lstdc++] ==> lib [stdc++]
arg [-lm] ==> lib [m]
arg [-lgomp] ==> lib [gomp]
arg [-lgcc_s] ==> lib [gcc_s]
arg [-lgcc] ==> lib [gcc]
arg [-lpthread] ==> lib [pthread]
arg [-lc] ==> lib [c]
arg [-lgcc_s] ==> lib [gcc_s]
arg [-lgcc] ==> lib [gcc]
arg [/usr/lib/gcc/x86_64-linux-gnu/9/crtendS.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu/crtn.o] ==> ignore
arg [/usr/lib/gcc/x86_64-linux-gnu/9/crtoffloadend.o] ==> ignore
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9] ==> [/usr/lib/gcc/x86_64-linux-gnu/9]
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/x86_64-linux-gnu] ==> [/usr/lib/x86_64-linux-gnu]
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…/…/lib] ==> [/usr/lib]
collapse library dir [/lib/x86_64-linux-gnu] ==> [/lib/x86_64-linux-gnu]
collapse library dir [/lib/…/lib] ==> [/lib]
collapse library dir [/usr/lib/x86_64-linux-gnu] ==> [/usr/lib/x86_64-linux-gnu]
collapse library dir [/usr/lib/…/lib] ==> [/usr/lib]
collapse library dir [/usr/lib/gcc/x86_64-linux-gnu/9/…/…/…] ==> [/usr/lib]
implicit libs: [stdc++;m;gomp;gcc_s;gcc;pthread;c;gcc_s;gcc]
implicit dirs: [/usr/lib/gcc/x86_64-linux-gnu/9;/usr/lib/x86_64-linux-gnu;/usr/lib;/lib/x86_64-linux-gnu;/lib]
implicit fwks: []

Determining if the include file omp.h exists passed with the following output:
Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/make cmTC_b18b3/fast && /usr/bin/make -f CMakeFiles/cmTC_b18b3.dir/build.make CMakeFiles/cmTC_b18b3.dir/build
make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’
Building CXX object CMakeFiles/cmTC_b18b3.dir/CheckIncludeFile.cxx.o
/usr/bin/c++ -std=c++11 -o CMakeFiles/cmTC_b18b3.dir/CheckIncludeFile.cxx.o -c /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp/CheckIncludeFile.cxx
Linking CXX executable cmTC_b18b3
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_b18b3.dir/link.txt --verbose=1
/usr/bin/c++ CMakeFiles/cmTC_b18b3.dir/CheckIncludeFile.cxx.o -o cmTC_b18b3
make[1]: Leaving directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’
Determining if the include file cmath exists passed with the following output:
Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp
Run Build Command(s):/usr/bin/make cmTC_2d8f7/fast && /usr/bin/make -f CMakeFiles/cmTC_2d8f7.dir/build.make CMakeFiles/cmTC_2d8f7.dir/build
make[1]: Entering directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’
Building CXX object CMakeFiles/cmTC_2d8f7.dir/CheckIncludeFile.cxx.o
/usr/bin/c++ -std=c++11 -o CMakeFiles/cmTC_2d8f7.dir/CheckIncludeFile.cxx.o -c /mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp/CheckIncludeFile.cxx
Linking CXX executable cmTC_2d8f7
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_2d8f7.dir/link.txt --verbose=1
/usr/bin/c++ CMakeFiles/cmTC_2d8f7.dir/CheckIncludeFile.cxx.o -o cmTC_2d8f7
make[1]: Leaving directory ‘/mnt/respaldos/executables/lammps-2Jul2021/buildKokkos/CMakeFiles/CMakeTmp’

Using the -C flag multiple times in different cmake calls can cause problems due to unexpected behavior when CMake decides that the configuration cache is inconsistent and must be erased.
What happens, if you change your CMake configuration the following way (this is for current master, latest patch)?

cd lammps
rm -rf build; mkdir build; cd build

cmake  -C ../cmake/presets/kokkos-cuda.cmake \
 -C ../cmake/presets/basic.cmake \
 -D BUILD_MPI=yes -D PKG_OPENMP=yes \
 -D Kokkos_ARCH_MAXWELL50=no -D Kokkos_ARCH_PASCAL61=yes \
 -D Kokkos_ENABLE_OPENMP=yes -D PKG_REAXFF=yes \
 -D PKG_GPU=yes -D GPU_API=CUDA -D GPU_ARCH=sm_61 ../cmake

This preset has been renamed from “minimal.cmake” to “basic.cmake” in that patch release as part of our reorganization of packages and making the names more consistent.

This is an issue of the bundled KOKKOS library. This was probably resolved with updating the bundled Kokkos. You can try building/installing Kokkos as an “external” packages (that is supported but the CMake build, although not tested by us but rather by some people that have a software that can be linked to LAMMPS and thus need a single consistent Kokkos library).

Hi Alex:

These are the results of executing your CMake configuration:

2Jul21

loading initial cache file …/cmake/presets/kokkos-cuda.cmake
loading initial cache file …/cmake/presets/basic.cmake
– The CXX compiler identification is unknown
– Check for working CXX compiler: /mnt/respaldos/executables/lammps-2Jul2021/lib/kokkos/bin/nvcc_wrapper
– Check for working CXX compiler: /mnt/respaldos/executables/lammps-2Jul2021/lib/kokkos/bin/nvcc_wrapper – broken
CMake Error at /usr/share/cmake-3.16/Modules/CMakeTestCXXCompiler.cmake:53 (message):
The C++ compiler

"/mnt/respaldos/executables/lammps-2Jul2021/lib/kokkos/bin/nvcc_wrapper"

is not able to compile a simple test program.

It fails with the following output:

Change Dir: /mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/make cmTC_e787f/fast && /usr/bin/make -f CMakeFiles/cmTC_e787f.dir/build.make CMakeFiles/cmTC_e787f.dir/build
make[1]: Entering directory '/mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeTmp'
Building CXX object CMakeFiles/cmTC_e787f.dir/testCXXCompiler.cxx.o
/mnt/respaldos/executables/lammps-2Jul2021/lib/kokkos/bin/nvcc_wrapper     -o CMakeFiles/cmTC_e787f.dir/testCXXCompiler.cxx.o -c /mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeTmp/testCXXCompiler.cxx
/mnt/respaldos/executables/lammps-2Jul2021/lib/kokkos/bin/nvcc_wrapper: line 562: nvcc: command not found
make[1]: *** [CMakeFiles/cmTC_e787f.dir/build.make:66: CMakeFiles/cmTC_e787f.dir/testCXXCompiler.cxx.o] Error 127
make[1]: Leaving directory '/mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeTmp'
make: *** [Makefile:121: cmTC_e787f/fast] Error 2

CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
CMakeLists.txt:17 (project)

– Configuring incomplete, errors occurred!
See also “/mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeOutput.log”.
See also “/mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeError.log”.

29Oct20

loading initial cache file …/cmake/presets/kokkos-cuda.cmake
loading initial cache file …/cmake/presets/basic.cmake
CMake Error: Error processing file: /mnt/respaldos/executables/lammps-29Oct20/cmake/presets/basic.cmake
– The CXX compiler identification is unknown
– Check for working CXX compiler: /mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper
– Check for working CXX compiler: /mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper – broken
CMake Error at /usr/share/cmake-3.16/Modules/CMakeTestCXXCompiler.cmake:53 (message):
The C++ compiler

"/mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper"

is not able to compile a simple test program.

It fails with the following output:

Change Dir: /mnt/respaldos/executables/lammps-29Oct20/build/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/make cmTC_4796a/fast && /usr/bin/make -f CMakeFiles/cmTC_4796a.dir/build.make CMakeFiles/cmTC_4796a.dir/build
make[1]: Entering directory '/mnt/respaldos/executables/lammps-29Oct20/build/CMakeFiles/CMakeTmp'
Building CXX object CMakeFiles/cmTC_4796a.dir/testCXXCompiler.cxx.o
/mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper     -o CMakeFiles/cmTC_4796a.dir/testCXXCompiler.cxx.o -c /mnt/respaldos/executables/lammps-29Oct20/build/CMakeFiles/CMakeTmp/testCXXCompiler.cxx
/mnt/respaldos/executables/lammps-29Oct20/lib/kokkos/bin/nvcc_wrapper: line 510: nvcc: command not found
make[1]: *** [CMakeFiles/cmTC_4796a.dir/build.make:66: CMakeFiles/cmTC_4796a.dir/testCXXCompiler.cxx.o] Error 127
make[1]: Leaving directory '/mnt/respaldos/executables/lammps-29Oct20/build/CMakeFiles/CMakeTmp'
make: *** [Makefile:121: cmTC_4796a/fast] Error 2

CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
CMakeLists.txt:12 (project)

– Configuring incomplete, errors occurred!
See also “/mnt/respaldos/executables/lammps-29Oct20/build/CMakeFiles/CMakeOutput.log”.
See also “/mnt/respaldos/executables/lammps-29Oct20/build/CMakeFiles/CMakeError.log”.

It looks similar to the error that you mentioned, so I will search how to update the bundled Kokkos. Please, let my know about any other suggestion!

This looks like there is a problem with your CUDA toolkit installation.

FYI, this is what happens with the same command on my machine:

[[email protected] build]$ cmake  -C ../cmake/presets/kokkos-cuda.cmake \
>  -C ../cmake/presets/basic.cmake \
>  -D BUILD_MPI=yes -D PKG_OPENMP=yes \
>  -D Kokkos_ARCH_MAXWELL50=no -D Kokkos_ARCH_PASCAL61=yes \
>  -D Kokkos_ENABLE_OPENMP=yes -D PKG_REAXFF=yes \
>  -D PKG_GPU=yes -D GPU_API=CUDA -D GPU_ARCH=sm_61 ../cmake
loading initial cache file ../cmake/presets/kokkos-cuda.cmake
loading initial cache file ../cmake/presets/basic.cmake
-- The CXX compiler identification is GNU 10.3.1
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /home/akohlmey/compile/lammps/lib/kokkos/bin/nvcc_wrapper - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found Git: /usr/bin/git (found version "2.31.1") 
-- Running check for auto-generated files from make-based build system
-- Found MPI_CXX: /usr/lib64/mpich/lib/libmpicxx.so (found version "3.1") 
-- Found MPI: TRUE (found version "3.1")  
-- Looking for C++ include omp.h
-- Looking for C++ include omp.h - found
-- Found OpenMP_CXX: -fopenmp (found version "4.5") 
-- Found OpenMP: TRUE (found version "4.5")  
-- Found JPEG: /usr/lib64/libjpeg.so (found version "62") 
-- Found PNG: /usr/lib64/libpng.so (found version "1.6.37") 
-- Found ZLIB: /usr/lib64/libz.so (found version "1.2.11") 
-- Found GZIP: /usr/bin/gzip  
-- Found FFMPEG: /usr/bin/ffmpeg  
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.7.3") 
-- Checking for module 'fftw3'
--   Found fftw3, version 3.3.8
-- Found FFTW3: /usr/lib64/libfftw3.so  
-- Looking for C++ include cmath
-- Looking for C++ include cmath - found
-- KOKKOS: Enabling CUDA LAMBDA function support
-- Setting default Kokkos CXX standard to 14
-- Setting policy CMP0074 to use <Package>_ROOT variables
-- The project name is: Kokkos
-- Compiler Version: 11.3.109
-- Using -std=c++14 for C++14 standard as feature
-- Built-in Execution Spaces:
--     Device Parallel: Kokkos::Cuda
--     Host Parallel: Kokkos::OpenMP
--       Host Serial: SERIAL
-- 
-- Architectures:
--  PASCAL61
-- Found CUDAToolkit: /usr/local/cuda-11.3/include (found version "11.3.109") 
-- Looking for C++ include pthread.h
-- Looking for C++ include pthread.h - found
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Success
-- Found Threads: TRUE  
-- Found TPLCUDA: TRUE  
-- Found TPLLIBDL: /usr/lib64/libdl.so  
-- Kokkos Devices: OPENMP;CUDA;SERIAL, Kokkos Backends: OPENMP;CUDA;SERIAL
-- Found CUDA: /usr/local/cuda-11.3 (found version "11.3") 
-- Generating style headers...
-- Generating package headers...
-- Generating lmpinstalledpkgs.h...
-- The following tools and libraries have been found and configured:
 * Git
 * MPI
 * OpenMP
 * JPEG
 * PNG
 * ZLIB
 * PkgConfig
 * FFTW3
 * CUDAToolkit
 * TPLCUDA
 * TPLLIBDL
 * Threads
 * CUDA

-- <<< Build configuration >>>
   Operating System: Linux Fedora 33
   Build type:       RelWithDebInfo
   Install path:     /home/akohlmey/.local
   Generator:        Unix Makefiles using /usr/bin/gmake
-- Enabled packages: GPU;KOKKOS;KSPACE;MANYBODY;MOLECULE;OPENMP;REAXFF;RIGID
-- <<< Compilers and Flags: >>>
-- C++ Compiler:     /home/akohlmey/compile/lammps/lib/kokkos/bin/nvcc_wrapper
      Type:          GNU
      Version:       10.3.1
      C++ Flags:     -O2 -g -DNDEBUG
      Defines:       LAMMPS_SMALLBIG;LAMMPS_MEMALIGN=64;LAMMPS_OMP_COMPAT=4;LAMMPS_JPEG;LAMMPS_PNG;LAMMPS_GZIP;LAMMPS_FFMPEG;FFT_FFTW3;FFT_FFTW_THREADS;LMP_USER_OMP;LMP_KOKKOS;FFT_CUFFT;LMP_GPU
-- <<< Linker flags: >>>
-- Executable name:  lmp
-- Static library flags:    
-- <<< MPI flags >>>
-- MPI_defines:      
-- MPI includes:     /usr/include/mpich-x86_64
-- MPI libraries:    /usr/lib64/mpich/lib/libmpicxx.so;/usr/lib64/mpich/lib/libmpi.so;
-- <<< GPU package settings >>>
-- GPU API:                  CUDA
-- CUDA Compiler:            /usr/local/cuda-11.3/bin/nvcc
-- GPU default architecture: sm_61
-- GPU binning with CUDPP:   OFF
-- CUDA MPS support:         OFF
-- GPU precision:            MIXED
-- Kokkos Arch: 
-- <<< FFT settings >>>
-- Primary FFT lib:  FFTW3
-- Using double precision FFTs
-- Using threaded FFTs
-- Kokkos FFT: cuFFT
-- Configuring done
-- Generating done
-- Build files have been written to: /home/akohlmey/compile/lammps/build

1 Like

Hi Axel,

I progressed in my problem adding the flag -D CMAKE_CXX_COMPILER=g++ to the cmake configuration that you suggested. Then,

cmake -C ../cmake/presets/kokkos-cuda.cmake -C ../cmake/presets/basic.cmake -D CMAKE_CXX_COMPILER=g++ -D BUILD_MPI=yes -D PKG_OPENMP=yes -D Kokkos_ARCH_MAXWELL50=no -D Kokkos_ARCH_PASCAL61=yes -D Kokkos_ENABLE_OPENMP=yes -D PKG_REAXFF=yes -D PKG_GPU=yes -D GPU_API=CUDA -D GPU_ARCH=sm_61 ../cmake

returned this:

Summary
loading initial cache file ../cmake/presets/kokkos-cuda.cmake
loading initial cache file ../cmake/presets/basic.cmake
-- The CXX compiler identification is GNU 9.3.0
-- Check for working CXX compiler: /usr/bin/g++
-- Check for working CXX compiler: /usr/bin/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found Git: /usr/bin/git (found version "2.25.1") 
-- Running check for auto-generated files from make-based build system
-- Found MPI_CXX: /usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi_cxx.so (found version "3.1") 
-- Found MPI: TRUE (found version "3.1")  
-- Looking for C++ include omp.h
-- Looking for C++ include omp.h - found
-- Found OpenMP_CXX: -fopenmp (found version "4.5") 
-- Found OpenMP: TRUE (found version "4.5")  
-- Found JPEG: /usr/lib/x86_64-linux-gnu/libjpeg.so (found version "80") 
-- Found PNG: /usr/lib/x86_64-linux-gnu/libpng.so (found version "1.6.37") 
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.11") 
-- Found GZIP: /usr/bin/gzip  
-- Found FFMPEG: /usr/bin/ffmpeg  
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1") 
-- Checking for module 'fftw3'
--   No package 'fftw3' found
-- Looking for C++ include cmath
-- Looking for C++ include cmath - found
-- KOKKOS: Enabling CUDA LAMBDA function support
-- Setting default Kokkos CXX standard to 14
-- Setting policy CMP0074 to use <Package>_ROOT variables
-- The project name is: Kokkos
-- Compiler Version: 10.1.243
-- kokkos_launch_compiler (/mnt/respaldos/executables/lammps-2Jul2021/lib/kokkos/bin/kokkos_launch_compiler) is enabled...
-- Using -std=c++14 for C++14 standard as feature
-- Built-in Execution Spaces:
--     Device Parallel: Kokkos::Cuda
--     Host Parallel: Kokkos::OpenMP
--       Host Serial: SERIAL
-- 
-- Architectures:
--  PASCAL61
-- Found CUDAToolkit: /usr/include (found version "10.1.243") 
-- Looking for C++ include pthread.h
-- Looking for C++ include pthread.h - found
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Failed
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found TPLCUDA: TRUE  
-- Found TPLLIBDL: /usr/lib/x86_64-linux-gnu/libdl.so  
-- Kokkos Devices: OPENMP;CUDA;SERIAL, Kokkos Backends: OPENMP;CUDA;SERIAL
-- Found CUDA: /usr (found version "10.1") 
-- Generating style headers...
-- Generating package headers...
-- Generating lmpinstalledpkgs.h...
-- The following tools and libraries have been found and configured:
 * Git
 * MPI
 * OpenMP
 * JPEG
 * PNG
 * ZLIB
 * PkgConfig
 * TPLCUDA
 * TPLLIBDL
 * Threads
 * CUDA

-- <<< Build configuration >>>
   Operating System: Linux Ubuntu 20.04
   Build type:       RelWithDebInfo
   Install path:     /home/g00/.local
   Generator:        Unix Makefiles using /usr/bin/make
-- Enabled packages: GPU;KOKKOS;KSPACE;MANYBODY;MOLECULE;OPENMP;REAXFF;RIGID
-- <<< Compilers and Flags: >>>
-- C++ Compiler:     /usr/bin/g++
      Type:          GNU
      Version:       9.3.0
      C++ Flags:     -O2 -g -DNDEBUG
      Defines:       LAMMPS_SMALLBIG;LAMMPS_MEMALIGN=64;LAMMPS_OMP_COMPAT=4;LAMMPS_JPEG;LAMMPS_PNG;LAMMPS_GZIP;LAMMPS_FFMPEG;FFT_KISS;LMP_USER_OMP;LMP_KOKKOS;LMP_GPU
-- <<< Linker flags: >>>
-- Executable name:  lmp
-- Static library flags:    
-- <<< MPI flags >>>
-- MPI_defines:      
-- MPI includes:     /usr/lib/x86_64-linux-gnu/openmpi/include/openmpi;/usr/lib/x86_64-linux-gnu/openmpi/include
-- MPI libraries:    /usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi_cxx.so;/usr/lib/x86_64-linux-gnu/openmpi/lib/libmpi.so;
-- <<< GPU package settings >>>
-- GPU API:                  CUDA
-- CUDA Compiler:            /usr/bin/nvcc
-- GPU default architecture: sm_61
-- GPU binning with CUDPP:   OFF
-- CUDA MPS support:         OFF
-- GPU precision:            MIXED
-- Kokkos Arch: 
-- <<< FFT settings >>>
-- Primary FFT lib:  KISS
-- Using double precision FFTs
-- Using non-threaded FFTs
-- Kokkos FFT: KISS
-- Configuring done
-- Generating done
-- Build files have been written to: /mnt/respaldos/executables/lammps-2Jul2021/build

It looks very similar to your result except for the line “No package ‘fftw3’ found”, but I also got this message in my previous installation. So, at this point, I thought my problem was solved, but when I executed cmake --build . it returned:

Summary
Scanning dependencies of target nvc_get_devices
[  0%] Building CXX object CMakeFiles/nvc_get_devices.dir/mnt/respaldos/executables/lammps-2Jul2021/lib/gpu/geryon/ucl_get_devices.cpp.o
[  0%] Linking CXX executable nvc_get_devices
[  0%] Built target nvc_get_devices
[  0%] Building NVCC fatbin file cuda_compile_fatbin_1_generated_lal_zbl.cu.fatbin
ERROR: No supported gcc/g++ host compiler found, but clang-8 is available.
       Use 'nvcc -ccbin clang-8' to use that instead.
CMake Error at cuda_compile_fatbin_1_generated_lal_zbl.cu.fatbin.RelWithDebInfo.cmake:212 (message):
  Error generating
  /mnt/respaldos/executables/lammps-2Jul2021/build/cuda_compile_fatbin_1_generated_lal_zbl.cu.fatbin

make[2]: *** [CMakeFiles/gpu.dir/build.make:751: cuda_compile_fatbin_1_generated_lal_zbl.cu.fatbin] Error 1
make[1]: *** [CMakeFiles/Makefile2:1008: CMakeFiles/gpu.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

On the other hand, If I replace g++ by clang-8 in -D CMAKE_CXX_COMPILER the result shows:

Summary
loading initial cache file ../cmake/presets/kokkos-cuda.cmake
loading initial cache file ../cmake/presets/basic.cmake
-- The CXX compiler identification is Clang 8.0.1
-- Check for working CXX compiler: /usr/bin/clang-8
-- Check for working CXX compiler: /usr/bin/clang-8 -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found Git: /usr/bin/git (found version "2.25.1") 
-- Running check for auto-generated files from make-based build system
-- Could NOT find MPI_CXX (missing: MPI_CXX_WORKS) 
CMake Error at /usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
  Could NOT find MPI (missing: MPI_CXX_FOUND)
Call Stack (most recent call first):
  /usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.16/Modules/FindMPI.cmake:1688 (find_package_handle_standard_args)
  CMakeLists.txt:255 (find_package)


-- Configuring incomplete, errors occurred!
See also "/mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeOutput.log".
See also "/mnt/respaldos/executables/lammps-2Jul2021/build/CMakeFiles/CMakeError.log".

I never was so close to solving this. I’m very thanks to you!

You are addressing the problem from the wrong angle. Key issue is that your need the nvcc wrapper to work for KOKKOS, which requires that nvcc works out of the box, which fails because your Cuda toolkit version is too old (or your gcc too new). Trying with clang is opening a new can of worms (and won’t work the way you try anyway). The current CUDA version (11.3) should work with your gcc (it supports up to gcc 10,IIRC).

This is all getting to be too much effort for a rather questionable gain considering the low performance of your GPU, especially with double precision floating point operations. The LAMMPS (and KOKKOS) CMake scripts expect that you have a working build environment, which is not the case.

1 Like

Okay! So I will check how to solve the problems of my environment. Thanks a lot!