How to run lammps with GPU in windows?

Hello, everyone!

At first, I would be thankful to Axel, who answer my question about fix bond/swap command in 2016-10-14

and I think if someone use the fix bond/swap, he should use restart commd to output bond connecting infomation

Next it is my problem:

Before we install GPU in our cluster, I test GPU package in Windows.

  1. First, the lmp_mpi.exe works well with MPICH2. The test srcipt is in.chain(data.chain), which is in benckmark folder,

although I change the run commd from 100 to 1000. And cpu time is 6s

  1. Then I install cuda_8.0.27_windows.exe in my Windows7 (I just install, and do nothing else)

so I could use “mpiexec -localonly 2 lmp_mpi -in in.chain -sf gpu -pk gpu 1” in cmd

3)The program could run, but the time is longer, cpu time is 25s!

I find several problems in log.lammps:

1]52.5% CPU use with 2 MPI tasks x 1 OpenMP threads. In MPI, this should be nearly 100%

2]Device time infor(average)==>CPU Idle_Time: 15.8067s

So, it means there are wrong setting in my Window?

Additionly, there is suggestion in GPU exemples:

I use the in.lj.titan in benck/FERMI folder, but the package command is illegal

“package gpu force/neigh 0 0 1”

I think this commads have changed its format

Best wishes,

yjruan

Hello, everyone!

At first, I would be thankful to Axel, who answer my question about fix
bond/swap command in 2016-10-14

and I think if someone use the fix bond/swap, he should use restart commd to
output bond connecting infomation

Next it is my problem:

Before we install GPU in our cluster, I test GPU package in Windows.

which GPU? not all GPUs are equal. some have impressive performance,
some flat out suck (when used for GPU computing).

1) First, the lmp_mpi.exe works well with MPICH2. The test srcipt is
in.chain(data.chain), which is in benckmark folder,

the "canonical" test is the LJ benchmark.

although I change the run commd from 100 to 1000. And cpu time is 6s

if you want to see good GPU acceleration, it is usually better to
increase the system size.

2) Then I install cuda_8.0.27_windows.exe in my Windows7 (I just install,
and do nothing else)

so I could use "mpiexec -localonly 2 lmp_mpi -in in.chain -sf gpu -pk gpu
1" in cmd

3)The program could run, but the time is longer, cpu time is 25s!

I find several problems in log.lammps:

1]52.5% CPU use with 2 MPI tasks x 1 OpenMP threads. In MPI, this should be
nearly 100%

2]Device time infor(average)==>CPU Idle_Time: 15.8067s

So, it means there are wrong setting in my Window?

impossible to say without more information. please see the second paragraph of:

http://rpm.lammps.org/windows.html

Additionly, there is suggestion in GPU exemples:

I use the in.lj.titan in benck/FERMI folder, but the package command is
illegal

"package gpu force/neigh 0 0 1"

I think this commads have changed its format

correct. those are old. see the manual, or

http://lammps.sandia.gov/doc/package.html

for the correct syntax.

please note, that i don't have a (real) windows machine (especially
not with a proper GPU). the windows binaries are built on a linux
machine using a cross compiler. but i have received positive feedback
that the GPU acceleration works well with those windows binaries, if
OpenCL is set up correctly.

axel.