hybrid/overlay option with reax/c and table potential not working in Kokkos

Hello

I am trying to use the hybrid/overlay option in Kokkos. I am using the reax/c and a tabulated potential for the system. I get a cuda runtime error as follows.

terminate called after throwing an instance of ‘std::runtime_error’
what(): cudaDeviceSynchronize() error( cudaErrorIllegalAddress): an illegal memory access was encountered …/…/lib/kokkos/core/src/Cuda/Kokkos_Cuda_Impl.cpp:119
Traceback functionality not available

This is part of my input script where I specify the potentials.

pair_style hybrid/overlay reax/c NULL checkqeq no table linear 4701

pair_coeff * * reax/c ffield.reax.PtNiCHO_2016 C C C O O
pair_coeff 45 45 none
pair_coeff 45 45 table O2_pot_LAMMPS.dat O2_TRUHLAR 5.0

Also the same setup works with MPI in multiple cpus.
Both the individual potentials also work within Kokkos.
So I think the issue is with the hybrid/overlay option in Kokkos.
I have tried this both in my workstation where I installed the packaged “lammps_kokkos_cuda_mpi” and in Pleiades where I installed the package “lammps_kokkos_cuda_hpempt”. I get the same error.

Regards

S.G.Krishnan

4th year Graduate student

Computational Kinetics Group (CKG)

Dept of Mechanical Engineering

University of Illinois at Urbana-Champaign

E-mail - [email protected]…1218…

[email protected]…92…

Ph no : +12179795383

FYI, this is best reported as an Issue in the LAMMPS project page on GitHub at: https://github.com/lammps/lammps/issues
please include/attache a minimal but complete input deck, so that developers can easily reproduce the issue.

thanks,
axel.

p.s.: you do not say which version of LAMMPS (i.e. which date is printed on the very first line of output) you are using. before reporting an issue, it is good practice to re-test with the very latest development version of LAMMPS to make certain, that you do not report an issue, that has already been addressed.

I’d be happy to take a look, but as Axel mentioned, a small reproducer would be very helpful.

Thanks,

Stan