Importing polyethylene.emc from ./lib directory

Hello EMC,
I am willing to create a crystalline polyethylene, which will be run in EMC simulation.

I found the polyethylene crystalline.emc script in ./lib direction.

However, when I tried to run with emc_linux.exe polyethylene.emc the linux terminal only shows a following message:

My question are these:

  1. How can I import the crystalline PE emc script?
  2. Is is okay to change the .emc file to run EMC moves without changing .esh file?

I tried to make .esh file, as following.

the code worked to make .emc file.

unfortunately, when I run the emc_linux.exe, the error occurs as follow:

Does anyone know how to fix this?

Dear User,

Regarding your first post

The polyethylene.emc file in the lib directory is a native EMC input/output format and holds the crystalline structure for united atom polyethylene. It stores positions, force field parameters, etc. It is meant to be used in conjunction with an EMC script. One can write these EMC scripts themselves, or use EMC Setup to generate one. The latter would generate an EMC Script file called build.emc. One can use to generate an EMC Setup suggestion for importing by import [name]

The latter will write a file called name.esh or setup.esh when name is omitted. A more complex EMC Script example for polyethylene can be found in


The latter is a suggestion for how to create input structures for united atom semicrystalline polyethylene.

Regarding your second post

You trying to import a polyethylene crystal structure, which already contains group definitions for the methyl group, which is using EMC not as intended. You do not have to import the polyethylene crystal structure, if you intend to only build amorphous polyethylene. I would suggest using


if you are interested in generating semicrystalline polyethylene.

Thank you for your reply.

It seems that there is no …/polymer/polyethylene/build.emc file in 9.4.4 version.
But I’ve found it in v9.4.2

When I run the emc_linux build.emc, there are several following problems

Errors occur differently every time I run the simulation, as follow:


Can you help me to solve this?

I’ve tried without cutting the structure by erasing the part below in ~/build/polymer/build.emc

It has run succesfully, but I’ve come across the other problem.

the result structure has shown to be placed outside of the simulation box.

Any help would be appreciated.

(I guess solving the cut&remove section might fix this problem)