Inquiry About Use of comm_modify


When I am trying to run my simulation of pouring ‘V’ shape particle in the simulation box, I am facing a problem like this: “Rigid body extent > ghost cutoff - use comm_modify cutoff”. Changing the cutoff distance seems not solving the issue. I am looking for any suggestions regarding the issue. Thank you.

Yeasir Mohammad Akib

Most likely you are not using the recommended command correctly. But without more details or a simple way to reproduce the issue there is no way to make a meaningful suggestion.

Dear Professor Akohlmey,

I am sharing my code for further suggestions.

Pour 2d granular particles into container

dimension 2

lattice sq 0.95
atom_style sphere
atom_modify map array
boundary f fm p
newton off
comm_modify vel yes cutoff 50

fix prop all property/atom mol ghost yes

region reg block -30 380 0 200 -0.5 0.5 units box
create_box 1 reg

region substratefirst block -25 370 20 100 -0.5 0.5 units box

create_atoms 1 region substratefirst units box

group 1 id < 2

group 2 region substratefirst

neighbor 0.2 bin
neigh_modify delay 0

pair_style gran/hertz/history 4000.0 NULL 350.0 NULL 0.5 0
pair_coeff * *

timestep 0.001

fix 1 all nve/sphere
fix 2 all gravity 3 spherical 0.0 -180.0 #Made gravity higher (3)

fix fridge 2 freeze

fix xwalls all wall/gran hertz/history 4000.0 NULL 100.0 NULL 0 1 &
xplane -30 NULL
fix ywalls all wall/gran hertz/history 4000.0 NULL 100.0 NULL 0 1 &
yplane 0 200

molecule object molecule.vshape
fix 3 all rigid/small molecule mol object

region slab block 10 210 140 160 -0.5 0.5 units box

label loopa
variable a loop 1
fix ins all pour 10 0 4767548 vol 0.8 10 &
region slab mol object rigid 3

fix 5 all enforce2d

compute 1 all erotate/sphere
compute Tsphere all temp/sphere
thermo_style custom step atoms ke c_1 vol
thermo_modify lost ignore norm no temp Tsphere
compute_modify Tsphere dynamic/dof yes

thermo 100

dump id all atom 200 dump.pour
dump 1 all custom 200 positions.lammpstrj id x y z vx vy vz diameter

run 120000

Yeasir Mohammad Akib

Your input is extremely hard to read for two reasons:

  1. you did not use triple backquotes (```) to stop the website from typesetting it and thus part of the symbols in your input are interpreted as markup instead of displayed
  2. your input is riddled with commented out lines of code

If you want somebody to take a closer look, you have to reduce your input to the absolute minimum that is required to reproduce the issue (and especially remove all those distracting comments) and provide a complete runnable input deck. Best is also to include a log file from a test run of your own.

Now, it is readable. I have tried to reduce the input size to a minimum to make the problem reproducible.
molecule.vshape (228 Bytes)

it is still missing the molecule file…

Professor Akohlmey, it’s uploaded in my previous comment.

Ok, the problem is rather straightforward.
When you define fix rigid, you apply it to group “all”, but that will apply for rigid/small not just to the inserted objects, but also to the large group of atoms that you have already created. Such a large rigid object, however, is not suitable for for fix rigid/small. Hence the error (note the “small” in fix rigid/small).

I also is not necessary to turn those into a rigid object anyway.

if you change your input to apply fix rigid/small to only apply to an initially empty group, the rest of the input will work as it seems to be intended. and you can drop the “comm_modify cutoff 50” option at the top, too.:

molecule object molecule.vshape
group inserted empty
fix 3 inserted rigid/small molecule mol object

Yes, Professor, it worked.