installing lammps on linux cluster...

please alway copy the mailing list when replying. thanks.

Thanks Axel,

I have also tried the default fftw by leaving empty all the FFT flags in the
make file, but it is still giving the same error (attached).

whenever you change the makefile, you have to delete all previous
objects with: make clean-openmpi
this is clearly explained in the LAMMPS installation instructions.
please re-read them very carefully.

When I checked the fftw installation (using "make check") it states that the
fft is installed correctly: "FFTW transforms passed basic tests!"

that doesn't mean anything. it also has to be consistent with your
edits to the makefile and the compiler that is hidden in the mpi
wrappers you use in lammps.

(please see the check.out file).
I am correctly referring to the installed fftw library and fftw include
files in the FFT flags but still it did not help.

not you don't. otherwise you would not get the error. i compile the
latest LAMMPS version regularly with different versions of FFTW and it
works without a hitch. the problem has to be with something that you
do or have done, not with LAMMPS.