Issue while running the lammps command

While I tried to run the lammps command (mpirun -np 6 lmp_mpi -in and simply the mpirun I am getting the error as “Invalid MIT-MAGIC-COOKIE-1 keyLAMMPS (20 Nov 2019)”, I was not getting an issue similar to this before , what should I do , what may be the possible reason for this. I even tried to “xhost + local;” command it didn’t work on that way either

This doesn’t look like a LAMMPS error. This is an error from the X11 protocol libraries, but LAMMPS does not use anything from X11. Whatever causes the message, it won’t affect LAMMPS.

Using the “xhost” command is a very, VERY bad idea. Without a firewall blocking access to your machine, it can allow anybody on the world to connect to your graphical session and monitor and manipulate everything you do and type. You don’t even use it correctly.

Thanks for the fast reply, but I got the error when I run the mpi command only , do reinstalling lammps will help.
How to revoke the permission that I gave to the xhost.

It is not an error, but a warning. It should not affect LAMMPS itself.

No. I have never seen this, but if it only happens when using “mpirun” then it is an issue of your MPI library configuration. I cannot know about this and this is not a LAMMPS issue, anyway.

See the documentation of the xhost command.

Thanks , I will look into those