Issue with libxc and vaccum

Scf is not converging when I am using libxc and giving vacuum in my calculation. Am I missing any thing to include in the calculation?. I am using the oxygen version.

Dear Vignesh,

in order to help you, it would be very useful if you could post your input.xml file and the species files you used in your calculation.

Pasquale Pavone
(exciting team)

Respected Pasquale Pavone

Thank You very much for your reply.

I took the input parameters as given in the tutorial for graphene in the exciting website and used functional from libxc instead of a xctype of GGA. xctype of GGA gave me correct results but in case of libxc functionals, the scf did not converge. Increasing the k grid values to 100 x 100 x 1, I was able to converge the scf but still the bandstructure did not match.

Thank You very much for your kind help.

I am not able to attach the files here, the website gives a error. I am writing the input here. I have made some edits (removed < symbol) as I faced issues writing the files. The input is the same as one given in the tutorial for graphene in the exciting website except I removed the XCTYPE and included the libxc parameters. I am using oxygen version.

Input FIle



structure speciespath="/home/vignesh/Apps/Exciting/exciting-oxygen_release/species">
crystal scale=“4.65”>
basevect> -0.5 0.8660254040 0.0
basevect> 0.5 0.8660254040 0.0
basevect> 0.0 0.0000000000 6.0
species speciesfile=“C.xml” rmt=“1.20”>
atom coord=“0.00000000 0.00000000 0.0”/>
atom coord=“0.33333333 0.33333333 0.0”/>


ngridk=“8 8 1”

path steps=“100”>
point coord=“0.0 0.0 0.0” label=“GAMMA”/>
point coord=“0.33333333 -0.33333333 0.0” label=“K” />
point coord=“0.5 -0.5 0.0” label=“M” />
point coord=“1.0 0.0 0.0” label=“GAMMA”/>



Species File

?xml version=“1.0” encoding=“UTF-8”?>
spdb xsi:noNamespaceSchemaLocation="…/…/xml/species.xsd" xmlns:xsi=“”>
sp chemicalSymbol=“C” name=“carbon” z="-6.00000" mass=“21894.16673”>
muffinTin rmin=“0.100000E-04” radius=“1.4500” rinf=“21.0932” radialmeshPoints=“250”/>
atomicState n=“1” l=“0” kappa=“1” occ=“2.00000” core=“true”/>
atomicState n=“2” l=“0” kappa=“1” occ=“2.00000” core=“false”/>
atomicState n=“2” l=“1” kappa=“1” occ=“1.00000” core=“false”/>
atomicState n=“2” l=“1” kappa=“2” occ=“1.00000” core=“false”/>
default type=“lapw” trialEnergy=“0.1500” searchE=“false”/>
custom l=“0” type=“apw+lo” trialEnergy=“0.1500” searchE=“true”/>
custom l=“1” type=“apw+lo” trialEnergy=“0.1500” searchE=“true”/>

Thanks and Regards

Hi Vignesh,

I feel like you might have answered the question. Have you tried a few different built-in exciting functionals like LDA, PBE-SOL and also tried the same functionals but called from LibXC?

If so and there’s still a problem, it suggests there’s a problem with our libXC API.

Try it out and let us know how it goes.


Respected Sir,

I ran two calculations, First with LDA_PZ( in-built) and Second with XC_LDA_C_PZ and XC_LDA_X for correlation and exchange respectively from libxc. The SCF got converged and I am able to get correct band structure.

Thank You very much for your time and help. I would be grateful if you could share any idea why XC_GGA_C_PBE and XC_GGA_X_PBE did not work or its simply a wrong choice from my side?

Thanks and Regards

Pasquale spoke to me on Friday about this. He strongly suspects the problem is that for certain functionals/systems, it’s important to set approximately zero values of the density to zero.

This is done with exciting’s built-in functionals but (probably) not with the libXC functionals. I think he’s investigating further. In the meantime I’ll ask around w.r.t. libXC