Keyerror vasp_std

Can you put the entire stack trace?

Also, it should be “my_fworker.yaml” (with an underscore). It’s possible that the rlaunch command is not finding the file. If you can also attach your my_qadapter.yaml it would help debug


On Sat, May 5, 2018 at 2:24 PM, [email protected] wrote:


I am setting up atomate for the first time, on Stampede 2, following the instructions at . I can submit fireworks to run VASP, but they all fizzle. The traceback indicates line 110 in, called by run_task, is

vasp_cmd = env_chk(self[“vasp_cmd”], fw_spec)

and this calls the function env_check, but on line 59 of in the env_check function

return fw_spec[’_fw_env’][val[2:-2]]

leads to a KeyError: ‘vasp_cmd’

My “myfworker.yaml” reads as following

name: Stampede2

category: ‘’

query: ‘{}’


db_file: /work/04391/tg836903/stampede2/atomate/config/db.json

vasp_cmd: ibrun tacc_affinity vasp_std

scratch_dir: $SCRATCH

I have tried removing tacc_affinity, as well as enclosing the entire

ibrun tacc_affinity vasp_std

in single quotes, with no success. I also am not certain that it is reading scratch_dir correctly because it isn’t changing to scratch when it tries to run. I am able to find the vasp_std executable using “which vasp_std”.

If you know what the problem is, please let me know.

Thank you

You received this message because you are subscribed to the Google Groups “atomate” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit

For more options, visit