LAMMPS dump reader issue

I’m having trouble with the lammps dump reader. I am reading in the LAMMPS data file first to bring in topology information, and then using the load trajectory modifier to bring in the trajectory frames. From this simulation I have two dump files written by the same simulation. One is in dump_style atom. The other is with dump_style custom. The dump_style atom trajectory loads in fine. The dump_style custom trajectory keeps throwing errors. I’m using Ovito Pro v3.7.5. It seems to be an issue with persistence of data within Ovito.

Originally, the custom dump file had a few extra columns. I had removed two columns from the custom dump between simulation runs. Whenever I tried to read it with the “load trajectory” modifier, it would throw an error about the number of columns.

To test if it was a problem with the custom dump, I modified the custom dump file to print out the same columns as the atom style. Vimdiff showed that the files were identical. However, Ovito still had trouble loading the custom file. I then simply changed the name of the custom dump file, and then it loaded fine. If I changed the name back to the original filename, it threw the same error. This error persisted even if I closed and reopened Ovito or deleted the pipeline and started from scratch. Is this an issue others have ran into?

Could you please show me the LAMMPS dump commands that produced the files?

Also, if you could share the file with me via OVITO’s support email, that would be very helpful.

The commands for creating the two dump files are

dump 1 all custom 100 sys.lammpstrj id type xs ys zs
dump 2 all atom 100 asys.lammpstrj

Before making them output identical information with the above commands, the custom dump command was something like
dump 1 all custom 100 sys.lammpstrj id type xs ys zs vx vy vz

However, that custom dump also didn’t load properly. The failure to load seemed to occur after changing the number of particles in the system. Originally the system had a different number of particles, so I thought that might be the issue. Unfortunately I no longer have the file that was causing the issue and I haven’t been able to recreate it yet. I will keep trying to recreate the error and report back.

Yes, please let me know if you run into that error again, then we can investigate further.
In general, I don’t see why the Load Trajectory Modifier would fail here, as the LAMMPS dump file reader (LAMMPS dump file reader — OVITO User Manual 3.9.1 documentation) should safely deal with changing numbers of particles and particle properties in between animation frames. Moreover, the filename shouldn’t matter at all in this context.