lammps fresh build / lammps.cpp / invalid arugument error

Hello All,

I am a new user of LAMMPS and have built lammps on my desktop to test and learn.
I have built lammps with gcc-8 on Mint linux without any problem or error but-

when I tried to test the installation with running few of the examples,

I keep getting “ERROR: Invalid command-line argument (src/lammps.cpp:363)”.

Is there anyone who has faced this problem ??
any help would be greatly appreciated.

Thank you in advance


It would help a lot if you actually showed which command triggered this error. It might be an outdated example.

Hello Stefan,

I have built the latest stable-release(Aug-2017) and master-branch from github repository.
I both cases newly built lammps executable with ./lmp …/examples/* (any example input) gives the same error.

I have tried running all the examples from stable as well as master branch but have not been successful yet.

I don’t understand what am I doing wrong here.



I don’t understand what am I doing wrong here.

you haven’t read the documentation. or you have read it and are ignoring it.
this is not how you run LAMMPS.