LAMMPS installaion

Dear all,

I am trying to install LAMMPS with make options. I have the newest LAMMPS version (lammps-2Aug2023) in my Ubuntu-20.4 machine. To install it first I went into the dirctory of /path_to_lammps/src. Then I ran make mpi and I got the following error.
/home/diptesh/miniconda3/bin/…/lib/gcc/x86_64-conda_cos6-linux-gnu/7.3.0/…/…/…/…/x86_64-conda_cos6-linux-gnu/bin/ld: /home/diptesh/miniconda3/lib/ undefined reference to memcpy@GLIBC_2.14' /home/diptesh/miniconda3/bin/../lib/gcc/x86_64-conda_cos6-linux-gnu/7.3.0/../../../../x86_64-conda_cos6-linux-gnu/bin/ld: /home/diptesh/miniconda3/lib/ undefined reference to aligned_alloc@GLIBC_2.16’
/home/diptesh/miniconda3/bin/…/lib/gcc/x86_64-conda_cos6-linux-gnu/7.3.0/…/…/…/…/x86_64-conda_cos6-linux-gnu/bin/ld: /home/diptesh/miniconda3/lib/ undefined reference to `clock_gettime@GLIBC_2.17’
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:94: …/lmp_mpi] Error 1
make[1]: Leaving directory ‘/home/diptesh/Tools/LAMMPS_2023/lammps-2Aug2023/src/Obj_mpi’
make: *** [Makefile:397: mpi] Error 2
I have no clue, how to solve it. Any help will be very welcome.
Thanks and Regards,

You have a broken miniconda installation. Deactivate it (or better just remove the whole lot of it) and install compiler and mpi library through the ubuntu package manager and use that.

Thanks, @akohlmey. It solved the problem.