LAMMPS installation problem

Dear LAMMPS users,

I am a new user in laammps (for about two months). I have read many prior emails and I found them very useful.

I alread installed LAMMPS on my windows machine and there was no problem and I using cygwin as Linux interface. But when I tried to install it on the supercomputer, there are some problems. Actually, when I installed lammps with default or nor,al packages there was no problem. Now, I need to add more packages such as dipole, User-misc, and kspace.

My steps are:

  1. download lammps and copy the tar file in my SSH account on my school supercomputer, then un-tar the file via: tar -xzvf lammps.tar.gz

then, I turned one some packages when I am in the scr directory via: make yes-dipole and so on

I checked these packages via: make packages-status

Finally, I installed lammps via: make -j8 mpi

I saw two types of errors which is not mentioned in the mailing list.

Dear LAMMPS users,

I am a new user in laammps (for about two months). I have read many prior
emails and I found them very useful.

​[...]​

mpicxx -g -O3 -DLAMMPS_GZIP -DLAMMPS_MEMALIGN=64 -DMPICH_SKIP_MPICXX

-DOMPI_SKIP_MPICXX=1 -c ../pair_list.cpp
../pair_list.cpp(88): error: expected a ";"
    const dbl3_t * _noalias const x = (dbl3_t *) atom->x[0];
                            ^

../pair_list.cpp(89): error: "restrict" has already been declared in the
current scope
    dbl3_t * _noalias const f = (dbl3_t *) atom->f[0];

​this is known and documented and has been answered on the mailing list
several times. you are compiling with intel compilers and thus must add the
-restrict flag to CCFLAGS.

axel.​

Dear Professor Axel:

I did what you said as you can see here. This is where I added “-restrict”

---------------------------------------------------------------------

compiler/linker settings

specify flags and libraries needed for your compiler

CC = mpicxx
CCFLAGS = -g -O3 -restrict
SHFLAGS = -fPIC
DEPFLAGS = -M

Dear Professor Axel:

I did what you said as you can see here. This is where I added "-restrict"

# ---------------------------------------------------------------------
# compiler/linker settings
# specify flags and libraries needed for your compiler

CC = mpicxx
CCFLAGS = -g -O3 -restrict
SHFLAGS = -fPIC
DEPFLAGS = -M

------------------------------------------------------------
------------------
but I saw this error when I compile lammps

ermo.o timer.o universe.o update.o variable.o velocity.o verlet.o
write_coeff.o write_data.o write_dump.o write_restart.o -o ../lmp_mpi
/usr/global/intel/Compiler/11.1/046/lib/intel64/libimf.so: warning:
warning: feupdateenv is not implemented and will always fail

​this is a warning, not an error.​

size ../lmp_mpi
   text data bss dec hex filename
9303125 196672 17128 9516925 91377d ../lmp_mpi
make[1]: warning: Clock skew detected. Your build may be incomplete.

​this is a warning, not an error.​ have you tested the resulting
executable? either your home directory is mounted on a networked file
system, where the time on the file server is not synchronized with a proper
time server, or the time on your machine is set (way?) back.

make[1]: Leaving directory `/home1/hemedaaa/lammps-17Nov16/src/Obj_mpi'
[[email protected] src] cd \[[email protected]\.\.\.6729\.\.\. \~\] cd lammps-17Nov16/src/
[[email protected] src] make clean\-all rm \-rf Obj\_\* \[[email protected]\.\.\.6729\.\.\. src\] cd
[he[email protected] ~]$ rm -r lammps-17Nov16/

​this is just deleting everything. why?​

​axel.​