lammps installation

Hi every body

I want to compile LAMMPS on a cluster, but I receive the following error:
would you please help me?
Thanks
Saly

[[email protected]…3395…:/work/saly/lammps-10Aug10/src] make custom
make[1]: Entering directory /gwork/saly/lammps-10Aug10/src/Obj_custom' Makefile:12: *** missing separator. Stop. make[1]: Leaving directory /gwork/saly/lammps-10Aug10/src/Obj_custom’
make: *** [custom] Error 2

yo can see the lmp_custom in the following:

linux = RedHat Linux box, Intel icc, Intel ifort, MPICH2, FFTW

SHELL = /bin/sh

---------------------------------------------------------------------

compiler/linker settings

specify flags and libraries needed for your compiler

CC = compile -intel
CCFLAGS = -O -I…/…/lib/poems -DFFT_FFTW -DLAMMPS_GZIP
-I/opt/sharcnet/fftw/2.1.5/intel/include
DEPFLAGS = -M
LINK = compile -intel -lmpi -llapack
LINKFLAGS = -O -L/opt/sharcnet/fftw/2.1.5/lib -L…/…/lib/poems -L…/…/lib/meam -L…/…/lib/atc -L…/…/lib/reax
USRLIB = -ldfftw -ldrfftw -lpoems -lmeam
#LIB = -lstdc++
ARCHIVE = ar
ARFLAGS = -rc
SIZE = size

---------------------------------------------------------------------

LAMMPS-specific settings

specify settings for LAMMPS features you will use

LAMMPS ifdef options, see doc/Section_start.html

LMP_INC = -DLAMMPS_GZIP

MPI library, can be src/STUBS dummy lib

INC = path for mpi.h, MPI compiler settings

PATH = path for MPI library

LIB = name of MPI library

MPI_INC = -DMPICH_SKIP_MPICXX
MPI_PATH =
MPI_LIB = -lmpich -lpthread

FFT library, can be -DFFT_NONE if not using PPPM from KSPACE package

INC = -DFFT_FFTW, -DFFT_INTEL, -DFFT_NONE, etc, FFT compiler settings

PATH = path for FFT library

LIB = name of FFT library

FFT_INC = -DFFT_FFTW
FFT_PATH =
FFT_LIB = -ldfftw

additional system libraries needed by LAMMPS package libraries

these settings are IGNORED if the corresponding LAMMPS package

(e.g. gpu, meam) is NOT included in the LAMMPS build

SYSLIB = names of libraries

SYSPATH = paths of libraries

gpu_SYSLIB = -lcudart
meam_SYSLIB = -lifcore -lsvml -lompstub -limf
reax_SYSLIB = -lifcore -lsvml -lompstub -limf
user-atc_SYSLIB = -lblas -llapack

gpu_SYSPATH = -L/usr/local/cuda/lib64
meam_SYSPATH = -L/opt/intel/fce/10.0.023/lib
reax_SYSPATH = -L/opt/intel/fce/10.0.023/lib
user-atc_SYSPATH =

---------------------------------------------------------------------

build rules and dependencies

no need to edit this section

include Makefile.package

EXTRA_INC = (LMP_INC) (PKG_INC) (MPI_INC) (FFT_INC)
EXTRA_PATH = (PKG_PATH) (MPI_PATH) (FFT_PATH) (PKG_SYSPATH)
EXTRA_LIB = (PKG_LIB) (MPI_LIB) (FFT_LIB) (PKG_SYSLIB)

Link target

(EXE): (OBJ)
(LINK) (LINKFLAGS) (EXTRA_PATH) (OBJ) (EXTRA_LIB) (LIB) -o (EXE) (SIZE) $(EXE)

Library target

lib: (OBJ) (ARCHIVE) (ARFLAGS) (EXE) $(OBJ)

Compilation rules

.o:.cpp
(CC) (CCFLAGS) (EXTRA_INC) -c <

.d:.cpp
(CC) (CCFLAGS) (EXTRA_INC) (DEPFLAGS) < > @

Individual dependencies

DEPENDS = (OBJ:.o=.d) include (DEPENDS)

Hi every body

I want to compile LAMMPS on a cluster, but I receive the following error:
would you please help me?

this is a makefile error and not a lammps error.
check the syntax of your *main* makefile.
around line 12.

if you cannot figure it out, please find somebody
that knows about this locally.

axel.