LAMMPS run problems

Recently i use three types of interatomic potential (eam/alloy, eam/fs, bop) for my system (Fe-Cu-H) and perform an energy minimization of the atomic coordinates of the system ,I meet an error that is ‘segmentation fault’. The version of LAMMPS is lammps3Mar20. The system has more than 650000 particles and does not include any dynamics process. I’ve successfully run the system without hydrogen atoms charging, and everything worked fine. Any comments/suggestions are highly appreciated. Thanks in advance!

This sounds like your problems are due to an “abuse” of the hybrid pair style. Even if you would not get a segmentation fault, you would probably get bad results.

Thanks for ur kind reply. It turns out the bop potential is not available for hybrid style. Recently i try to charge H atoms and replace Fe atoms to Cu atoms to build my model. Firstly i construct a BCC iron with edge dislocation by ATOMSK with lmp file which can be read by LAMMPS. Then i add two types of atom into it with LAMMPS code. However, the data file i got from “write_data” command after relaxation can’t be read by next dynamic process. So i checked the data file and i found some differences between lines, i guess the incorrect format caused the error when i run dynamic process. But i can’t find the reason why. And this happens only when i boost the model further. The version of LAMMPS is lammps3Mar20.
The data file looks like this:

This is not very helpful to give any advice.

This is now over two years old and we had two stable releases since and are gearing up for the next one. Nobody will take a closer look (for which more information and specifically files to reproduce are needed) unless you can show that there is an issue with a more recent version and best the current development version.