Lammps stuck after minimize

Lammps version: LAMMPS 64-bit 3Nov2022 with Python
Hello. I tried to run a 10000SPCEwater-90Na±90Cl- system with lammps(system from Material studio), but Lammps got stuck after minimization. Could not find out the reason, need help. THANK YOU!
btw, this problem did not occur when I try another system(10000SPCEwater-18Na±18Cl-)

-in file:
units real
atom_style	   full
pair_style     lj/cut/coul/long 10
kspace_style   ewald 1e-6
bond_style     harmonic
angle_style    harmonic

variable Ttarget 				equal 773.15
variable Ptarget 				equal 1000
variable Nrun					equal 10000
variable Nrun2					equal 50000
variable freq 					equal ${Nrun2}/100	

read_data data/solution10000_90_0.55.dat

mass 1 15.9994
mass 2 1.00794
# SPCE water model
set type 1 charge -0.8476
set type 2 charge +0.4238
# from john1998
pair_coeff 1   1   0.1554              3.166
pair_coeff 1   2   0                   0
pair_coeff 1   3   0.1421              2.758
pair_coeff 1   4   0.1247              3.783
pair_coeff 2   2   0                   0
pair_coeff 2   3   0                   0
pair_coeff 2   4   0                   0
pair_coeff 3   3   0.1300              2.350
pair_coeff 3   4   0.1140              3.375
pair_coeff 4   4   0.1000              4.400
# O-H from ClayFF2004
bond_coeff     1 554.1349 1
# H-O-H from ClayFF2004
angle_coeff    1 45.7696 109.47
thermo 1

# system minimize
group w type 1 2
fix 0 w setforce 0 0 0
velocity w set 0 0 0
minimize 1.0e-4 1.0e-6 100 1000
unfix 0
# system relaxation
velocity all create ${Ttarget} 999
fix 0 all shake 1.0e-4 200 0 b 1 a 1 
fix 1 all npt temp ${Ttarget} ${Ttarget} 100 iso ${Ptarget} ${Ptarget} 1000 
thermo_style   custom step time temp press density vol etotal ke pe
run ${Nrun}

# data collection
reset_timestep 0
dump           1 all custom ${freq} output/dump.${filename}.dat id type q xs ys zs
compute        rdf all rdf 1000 3 1 4 1 3 4 1 1
fix            saverdf all ave/time 1 ${Nrun2} ${Nrun2} c_rdf[*] file output/rdf.${filename}.dat mode vector
run ${Nrun2}

What has this to do with Python?

In general, when you are reporting something where LAMMPS is not behaving as you expect it, then you should be reporting what version of LAMMPS you are using and best provide more of your output than just the few lines where the bad behavior happens. Also, it would help to know what your exact command line is as that shows how many processors you are using. For example I can infer from the pieces of output, that you are using the omp suffix.

The most common situation where the behavior you describe happens is when your system geometry has a very high potential energy. Please note that you are wiping out the forces of the water molecules with the fix setforce command during minimization, i.e. your minimization will not be able to do a good job of reducing any excessive potential energy.

1 Like

Thanks! I have been learning Python lately, I thought of having typed ‘Lammps’, lol.
The problem have been solved, but I am confused whether the MINIMIZE command will drag an atom too far away from another it is bonded with, thus destroying the structure of the water molecule?
p.s. Thanks too for your other advice, which is very helpful for a beginner :slight_smile: