[lammps-users] Cannot safely add motion to Boron Nitride monolayer simulation

Hello All,

I’m running the lammps-30Apr2019 version of LAMMPS. My current issue is that, while I can get the positional data of the atoms correctly, every time I try to add some motion to my simulation, whether through the nvt fix or the velocity command, atoms start flying everywhere.

I’ve tried small ramp ups in temperatures using only using the nvt fix. In this case I’ve ramped up to 300K from 0.33 over the course of 1,000,000 timesteps but there won’t be any motion in the data output.

When I use the velocity command to initialize a beginning temperature the atoms will begin to move and then over the course of a few timesteps they will begin to fly everywhere. Below is my input file and I’ve also attached an output file. From what I can see, after the first timestep there is a major jump in energy but I’m not sure how to bypass this. I’ve have also tried decreasing the timestep down to 0.00001 as well, but the same problem persists. Please help with any tips or suggestions. Thank you in advance



units metal
dimension 3
boundary ​ p p p
atom_style atomic

myjobresults-3341594.txt (53.8 KB)

your geometry is bogus. check out the distances between the atoms. they are far too long. you won’t see anything happen at zero kelvin because your system is metastable due to symmetry, but as soon as the symmetry is broken everything is falling apart since the atoms are not where they “want to be”.

FYI, the data file examples/USER/misc/ilp_graphene_hbn/hBN_AA_prime_stack_2L_noH.data
in the LAMMPS distribution has two BN sheets. just compare it with your geometry and see for yourself.


Dr. Kohlmeyer,

I misunderstood the structure of the lattice command. Once fixed I was able to get my simulations to run properly

Thank You,