[lammps-users] deposition of molecular water on a glassy water substrate

Dear LAMMPS users and developers,

I’m trying to simulate the deposition of water molecules on a substrate made of glassy water.
Molecules are deposited using fix deposit, and integrated with NVE.
The substrate is integrated with NVT.

This setup has already been used for atomic liquids (see for example articles on deposition from Ludovic Berthier and coworkers).

When considering monoatomic water, deposited particles (with the chosen parameters) solidify on the substrate.
However, when considering molecular water (tip4p/2005), deposited molecules do thermalize with the substrate, but do not solidify and can eventually even scatter from the surface after performing some dynamics on it. This behavior is observed for temperatures of the substrate up to ~ 60 K, below which deposited molecules finally solidify.

If I perform deposition of molecular water without using the fix deposit, by considering as initial configuration of the system the same substrate of molecules (in NVT) plus extra molecules on the upper part of the box with negative velocity along z integrated with NVE, then deposited particles do solidify (I tried up to a temperature of the substrate of 180 K).
I attached the script used to deposit one molecule with fix deposit.

LAMMPS version: lammps-3Mar20

Thank you very much for any advice.

H2O.dat (422 Bytes)

Configuration_box.dat (91 KB)

in.tip4p (5.25 KB)

I did a couple of checks to try to figure out the reason why deposited water molecules (tip4p/2005) do not solidify on the glassy water substrate at temperatures for which they should.

First of all, instead of using fix deposit I created molecules on the upper part of the box with negative velocity along z and integrated them with NVE. What I get is the same result I got with fix deposit.

After that, I verified that this problem is solved (deposited water molecules solidify) by considering a cutoff for Coulombic interactions without long-range contributions (using pair_style lj/cut/tip4p/cut).

Therefore, I guess that something is not properly working with the kspace_modify command when new molecules are introduced in the system, either through the fix deposit or the create_atoms command.

I’m forwarding this to Stan.
It’s not clear to me that it’s a LAMMPS issue versus something more fundamental about your model.


Not sure, perhaps the Kspace interactions aren’t getting updated with fix deposit ​when atoms are added.

Dear developers and users,
Thank you very much for your answers.I was suspecting that the Kspace interactions aren’t getting updated with fix deposit when atoms are added.
Do you think one possible way to solve this problem is to make a loop to restart the simulation just after a new molecule is introduced in the box (if possible)?

Thank you for your help!
Kind regards,