[lammps-users] error in mpi run

I use the (29 Sep 2021) version of lammps. Also, my MPI version is mpich2-1.4.1p1-win-x86-64. The specification of my computer is given below:
Intel(R) Core™ i7-4500U cpu @ 1.80GHz 2.40 GHz
windows 8.1 is installed on my computer.
when I run my program with command: mpiexec -np 4 lmp -in first.txt
I get the following error (also the image of error is attached ) :
Error: error while connecting to host, no connection could be made because the target machine actively refused it.(10061)
how can solve this problem?
Thanks a lot.
with best regards.

Did you register the smpd service in administrator mode?
Have you tried using “-localonly” instead of “-np”?

Here is the corresponding text from the online docs:

After the installation of the MPICH software, it needs to be integrated into the system. For this you need to start a Command Prompt in Administrator Mode (right click on the icon and select it). Change into the MPICH2 installation directory, then into the subdirectory bin and execute smpd.exe -install.

MPI parallel executables have to be launched with mpiexec -localonly # lmp ... or mpiexec -np # lmp ... with “#” being then number of parallel processes to start. For the latter you may be asked for your password.

Hello Dr Kohlmeyer
Thanks for your rapid reply.

I had done all the mentioned points, but there is still the same error.
How can I solve this?
Thanks a lot.

I don’t really know. I have never experienced any issues, but I am not using Windows much.
There are two possible remedies I can think of. But for details on the second, you need to consult with a person that has more windows knowledge.

  • you may need to do a reboot
  • you may need to change your firewall settings to be less restrictive for the ports that LAMMPS needs to access for MPI communication.
1 Like

You need to register on windows: “mpiexec -register”
Then need to enter username and password. I have already made video on this topic. Please check link.