[lammps-users] input errors for indenation simulaitons

I just encountered one input problem for indentation simulations.
The following is the command I used to impose the indenter:

fix 3 all indent 10.0 sphere 0.0 0.0 8.0 5.0 vel 0.0 0.0 -0.01 units box

The format is exactly the same as one of the examples shown in the “fix indent” section in the user’s manual files. But when I run the code,
the error showed up “ERROR: Illegal fix indent command”. I suppose the problem is only caused by the format of my indent command. I checked the indent example in our code package and found there was no velocity control of the indenter. The movement of the indenter is realized through moving the initial coordinates of the center of the indenter step by step. I run that example and it can work. Then, I canceled the velocity part of my indent command:

fix 3 all indent 10.0 sphere 0.0 0.0 8.0 5.0 units box

The code can run without errors. Now I do not know what is going on and is there anyone who can give me some ideas? Thanks a lot!!

Regards
Xu

The syntax with vel is outdated. The current version
uses a more general format. I'm guessing you are
reading the doc page for an older version and running
a newer version. Note that the PDF file does not
get updated with every change to the code. But the
HTML doc pages do.

Steve

2010/5/27 huangxu <[email protected]>: